Cracking Sounds w/ Audio (Pipewire) Started Recently

Since I switched to EndeavourOS last year sound has been great compared to the Pulse/Alsa issue I had before in some distros where any sound coming through from the computer would produce cracking/static sounds. On those distros it was constant. Here on EOS it started several updates ago. It almost feels like the sound system goes to sleep and when it is triggered with sound, the cracking/static happens. It isn’t constant though. I can play music all day and it is fine. Any sudden sound triggers it. Anyone else experiencing this? It seems to have started back when this was posted on the Arch news… https://archlinux.org/news/undone-replacement-of-pipewire-media-session-with-wireplumber

Did you switch to wireplumber then? What happens if you switch back to pipewire-media-session ?

I followed the directions to switch back to pipewire-media-session, but the problem continues. Luckily it isn’t a constant issue like it was with Pulse/Alsa, where I had to kill it off and restart it. The problem continues though.

OK, so that means WirePlumber wasn’t the issue and you can swap back.

I’m facing this same issue, but only when I resume a video that was paused, and only in MPV.
After 3 seconds the cracking stops.

Edit: I disabled the amd-pstate, now using acpi-cpufreq again, and the problem still happens but its way better, 1 second and it normalizes.

So I think it is something with the power plan… I’m using the default Arch Kernel:

Linux eos 5.18.3-arch1-1 #1 SMP PREEMPT_DYNAMIC Thu, 09 Jun 2022 16:14:10 +0000 x86_64 GNU/Linux

I’ll test again with zen

Edit2: With zen-kernel and acpi-cpufreq the problem doesn’t happen.

https://wiki.archlinux.org/title/PipeWire#Noticeable_audio_delay_or_audible_pop/crack_when_starting_playback

My problem was related to the info mentioned above in the link above, fixed by following the instructions:

1 Like

I have this problem with my microphone and can not use pulse in teamspeak3. Alsa doesnt have this problem but somehow makes teamspeak use 100% CPU all the time…

I found the solution for my problem: https://gitlab.freedesktop.org/pipewire/pipewire/-/issues/2434

2 Likes