Cpupower/acpi-cpufreq can't use 'performance' governor

Hello, I have tried setting my cpu governor to performance using cpu-power and seems what-ever I do it doesn’t switch to performance, it keeps defaulting back to schedutil which has cpu frequency scaling and setting cpupower frequency-set -g performance doesn’t switch the governor and remains on schedutil even after a restart.
I’ve tried setting my min/max frequency in cpupower and that doesn’t work.
Is this a problem with acpi-cpufreq and if it is what other driver would you recommend, I’ve seen people recommend p4-clockmod but I’m unsure if that will force my cpu frequency to stay at max freq.

Update: it now uses performance mode after setting “echo ‘GOVERNOR=“performance”’ | sudo tee /etc/default/cpufrequtil”
But it is still not using the highest turbo speed I can get.

Input: cpupower frequency-info

Output:

analyzing CPU 0:
driver: acpi-cpufreq
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: 10.0 us
hardware limits: 1.60 GHz - 3.50 GHz
available frequency steps: 3.50 GHz, 3.50 GHz, 3.40 GHz, 3.20 GHz, 3.10 GHz, 3.00 GHz, 2.80 GHz, 2.70 GHz, 2.50 GHz, 2.40 GHz, 2.30 GHz, 2.10 GHz, 2.00 GHz, 1.90 GHz, 1.70 GHz, 1.60 GHz
available cpufreq governors: performance schedutil
current policy: frequency should be within 3.50 GHz and 3.50 GHz.
The governor “performance” may decide which speed to use
within this range.
current CPU frequency: 3.50 GHz (asserted by call to hardware)
boost state support:
Supported: yes
Active: yes
4300 MHz max turbo 4 active cores
4300 MHz max turbo 3 active cores
4300 MHz max turbo 2 active cores
4300 MHz max turbo 1 active cores

Without knowing anything about the CPU, could 3.5GHz be the maximum non-turbo clock and 4.3GHz the single-core boost?

1 Like

Hey I’ll follow this closely.
I never managed to get the proper governor to work right on EOS.

have you use powertop for Intel CPU ?

Another way to select a governor is to create a config file in /etc/tmpfiles.d with e.g.:
w /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor - - - - performance

4 Likes

Thank you that worked!

1 Like