Could not get file information for usr/lib/R/library/mgcv

Hi, today after I update my system I get some warnings, as follows

╰─> bsh > yay
[sudo] password for yuanhao: 
:: Synchronising package databases...
 endeavouros                                             22.0 KiB   113 KiB/s 00:00 [------------------------------------------------] 100%
 core                                                   129.3 KiB   305 KiB/s 00:00 [------------------------------------------------] 100%
 extra                                                    8.3 MiB  1519 KiB/s 00:06 [------------------------------------------------] 100%
 multilib                                               140.3 KiB   372 KiB/s 00:00 [------------------------------------------------] 100%
:: Searching AUR for updates...
:: Searching databases for updates...
 -> Missing AUR Debug Packages: jags-debug
 -> Flagged Out Of Date AUR Packages: forticlient-vpn  rstudio-desktop-bin
:: 20 packages to upgrade/install.
20  core/archlinux-keyring      20231222-1 -> 20240208-1
19  core/expat                  2.5.0-1    -> 2.6.0-1
18  core/gc                     8.2.4-1    -> 8.2.6-1
17  core/python                 3.11.6-1   -> 3.11.7-1
16  extra/babl                  0.1.106-1  -> 0.1.108-1
15  extra/ddcutil               2.1.2-1    -> 2.1.3-1
14  extra/ffmpeg                2:6.1.1-3  -> 2:6.1.1-5
13  extra/libadwaita            1:1.4.2-1  -> 1:1.4.3-1
12  extra/libhandy              1.8.2-1    -> 1.8.3-1
11  extra/libmanette            0.2.6-5    -> 0.2.7-1
10  extra/libmupdf              1.23.9-4   -> 1.23.10-1
 9  extra/libproxy              0.5.3-2    -> 0.5.4-1
 8  extra/polkit                124-1      -> 124-2
 7  extra/python-ml-dtypes      0.3.1-1    -> 0.3.2-1
 6  extra/python-pydantic       2.6.0-1    -> 2.6.1-1
 5  extra/python-pydantic-core  1:2.16.1-1 -> 1:2.16.2-1
 4  extra/python-uc-micro-py    1.0.2-1    -> 1.0.3-1
 3  extra/r                     4.3.2-3    -> 4.3.2-4
 2  extra/zathura-pdf-mupdf     0.4.1-14   -> 0.4.1-15
 1  multilib/lib32-expat        2.5.0-2    -> 2.6.0-1
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
 -> Excluding packages may cause partial upgrades and break systems
==> 
Sync Explicit (4): archlinux-keyring-20240208-1, zathura-pdf-mupdf-0.4.1-15, python-3.11.7-1, r-4.3.2-4
Sync Dependency (16): lib32-expat-2.6.0-1, python-pydantic-core-1:2.16.2-1, python-uc-micro-py-1.0.3-1, polkit-124-2, babl-0.1.108-1, libadwaita-1:1.4.3-1, expat-2.6.0-1, libmupdf-1.23.10-1, python-ml-dtypes-0.3.2-1, libhandy-1.8.3-1, python-pydantic-2.6.1-1, libmanette-0.2.7-1, ddcutil-2.1.3-1, gc-8.2.6-1, ffmpeg-2:6.1.1-5, libproxy-0.5.4-1
:: Synchronising package databases...
 endeavouros is up to date
 core is up to date
 extra is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Package (21)                Old Version  New Version  Net Change  Download Size

core/archlinux-keyring      20231222-1   20240208-1     0.00 MiB       1.16 MiB
extra/babl                  0.1.106-1    0.1.108-1      1.63 MiB       1.48 MiB
extra/ddcutil               2.1.2-1      2.1.3-1        0.00 MiB       0.65 MiB
core/expat                  2.5.0-1      2.6.0-1        0.02 MiB       0.11 MiB
extra/ffmpeg                2:6.1.1-3    2:6.1.1-5      0.01 MiB      11.64 MiB
core/gc                     8.2.4-1      8.2.6-1        0.00 MiB       0.23 MiB
multilib/lib32-expat        2.5.0-2      2.6.0-1        0.00 MiB       0.07 MiB
extra/libadwaita            1:1.4.2-1    1:1.4.3-1      0.01 MiB       0.55 MiB
extra/libhandy              1.8.2-1      1.8.3-1       -0.03 MiB       0.45 MiB
extra/libmanette            0.2.6-5      0.2.7-1        0.00 MiB       0.05 MiB
extra/libmupdf              1.23.9-4     1.23.10-1      0.00 MiB      25.97 MiB
extra/libproxy              0.5.3-2      0.5.4-1        0.00 MiB       0.03 MiB
extra/polkit                124-1        124-2          0.00 MiB       0.39 MiB
core/python                 3.11.6-1     3.11.7-1       0.00 MiB      13.93 MiB
extra/python-ml-dtypes      0.3.1-1      0.3.2-1        0.01 MiB       0.13 MiB
extra/python-pydantic       2.6.0-1      2.6.1-1        0.00 MiB       0.72 MiB
extra/python-pydantic-core  1:2.16.1-1   1:2.16.2-1    -0.02 MiB       1.56 MiB
extra/python-uc-micro-py    1.0.2-1      1.0.3-1        0.00 MiB       0.01 MiB
extra/r                     4.3.2-3      4.3.2-4       -0.02 MiB      44.32 MiB
extra/vapoursynth                        R65-1          3.13 MiB       0.95 MiB
extra/zathura-pdf-mupdf     0.4.1-14     0.4.1-15       0.00 MiB       0.01 MiB

Total Download Size:   104.42 MiB
Total Installed Size:  267.24 MiB
Net Upgrade Size:        4.76 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 python-pydantic-core-1:2.16.2-1-x86_64                1602.4 KiB  1080 KiB/s 00:01 [------------------------------------------------] 100%
 libmupdf-1.23.10-1-x86_64                               26.0 MiB  15.6 MiB/s 00:02 [------------------------------------------------] 100%
 babl-0.1.108-1-x86_64                                 1512.4 KiB  1532 KiB/s 00:01 [------------------------------------------------] 100%
 vapoursynth-R65-1-x86_64                               969.1 KiB  1173 KiB/s 00:01 [------------------------------------------------] 100%
 archlinux-keyring-20240208-1-any                      1189.5 KiB   523 KiB/s 00:02 [------------------------------------------------] 100%
 python-3.11.7-1-x86_64                                  13.9 MiB  2.82 MiB/s 00:05 [------------------------------------------------] 100%
 python-pydantic-2.6.1-1-any                            735.7 KiB   827 KiB/s 00:01 [------------------------------------------------] 100%
 ddcutil-2.1.3-1-x86_64                                 666.2 KiB   675 KiB/s 00:01 [------------------------------------------------] 100%
 libadwaita-1:1.4.3-1-x86_64                            563.8 KiB   723 KiB/s 00:01 [------------------------------------------------] 100%
 gc-8.2.6-1-x86_64                                      234.7 KiB   403 KiB/s 00:01 [------------------------------------------------] 100%
 libhandy-1.8.3-1-x86_64                                460.7 KiB   692 KiB/s 00:01 [------------------------------------------------] 100%
 polkit-124-2-x86_64                                    402.3 KiB   544 KiB/s 00:01 [------------------------------------------------] 100%
 ffmpeg-2:6.1.1-5-x86_64                                 11.6 MiB  1656 KiB/s 00:07 [------------------------------------------------] 100%
 expat-2.6.0-1-x86_64                                   116.9 KiB   573 KiB/s 00:00 [------------------------------------------------] 100%
 python-ml-dtypes-0.3.2-1-x86_64                        133.9 KiB   350 KiB/s 00:00 [------------------------------------------------] 100%
 libproxy-0.5.4-1-x86_64                                 28.3 KiB  65.4 KiB/s 00:00 [------------------------------------------------] 100%
 zathura-pdf-mupdf-0.4.1-15-x86_64                       11.8 KiB   493 KiB/s 00:00 [------------------------------------------------] 100%
 lib32-expat-2.6.0-1-x86_64                              69.6 KiB   111 KiB/s 00:01 [------------------------------------------------] 100%
 libmanette-0.2.7-1-x86_64                               54.5 KiB  94.6 KiB/s 00:01 [------------------------------------------------] 100%
 python-uc-micro-py-1.0.3-1-any                           9.3 KiB  17.8 KiB/s 00:01 [------------------------------------------------] 100%
 r-4.3.2-4-x86_64                                        44.3 MiB  1352 KiB/s 00:34 [------------------------------------------------] 100%
 Total (21/21)                                          104.4 MiB  3.08 MiB/s 00:34 [------------------------------------------------] 100%
error: failed retrieving file 'libmupdf-1.23.10-1-x86_64.pkg.tar.zst' from mirror.vinehost.net : The requested URL returned error: 404
error: failed retrieving file 'libmupdf-1.23.10-1-x86_64.pkg.tar.zst' from mirror.netweaver.uk : The requested URL returned error: 404
error: failed retrieving file 'zathura-pdf-mupdf-0.4.1-15-x86_64.pkg.tar.zst' from mirror.vinehost.net : The requested URL returned error: 404
error: failed retrieving file 'zathura-pdf-mupdf-0.4.1-15-x86_64.pkg.tar.zst' from mirror.netweaver.uk : The requested URL returned error: 404
(21/21) checking keys in keyring                                                    [------------------------------------------------] 100%
(21/21) checking package integrity                                                  [------------------------------------------------] 100%
(21/21) loading package files                                                       [------------------------------------------------] 100%
(21/21) checking for file conflicts                                                 [------------------------------------------------] 100%
(21/21) checking available disk space                                               [------------------------------------------------] 100%
warning: could not get file information for usr/lib/R/library/mgcv/po/it/
warning: could not get file information for usr/lib/R/library/mgcv/po/it/LC_MESSAGES/
warning: could not get file information for usr/lib/R/library/mgcv/po/it/LC_MESSAGES/R-mgcv.mo
warning: could not get file information for usr/lib/R/library/mgcv/po/it/LC_MESSAGES/mgcv.mo
:: Processing package changes...
( 1/21) upgrading expat                                                             [------------------------------------------------] 100%
( 2/21) upgrading archlinux-keyring                                                 [------------------------------------------------] 100%
==> Appending keys from archlinux.gpg...
==> Updating trust database...
gpg: next trustdb check due at 2024-04-10
( 3/21) upgrading babl                                                              [------------------------------------------------] 100%
( 4/21) upgrading ddcutil                                                           [------------------------------------------------] 100%
( 5/21) upgrading python                                                            [------------------------------------------------] 100%
( 6/21) installing vapoursynth                                                      [------------------------------------------------] 100%
( 7/21) upgrading ffmpeg                                                            [------------------------------------------------] 100%
( 8/21) upgrading gc                                                                [------------------------------------------------] 100%
( 9/21) upgrading lib32-expat                                                       [------------------------------------------------] 100%
(10/21) upgrading libproxy                                                          [------------------------------------------------] 100%
(11/21) upgrading libadwaita                                                        [------------------------------------------------] 100%
(12/21) upgrading libhandy                                                          [------------------------------------------------] 100%
(13/21) upgrading libmanette                                                        [------------------------------------------------] 100%
(14/21) upgrading libmupdf                                                          [------------------------------------------------] 100%
(15/21) upgrading polkit                                                            [------------------------------------------------] 100%
(16/21) upgrading python-ml-dtypes                                                  [------------------------------------------------] 100%
(17/21) upgrading python-pydantic-core                                              [------------------------------------------------] 100%
(18/21) upgrading python-pydantic                                                   [------------------------------------------------] 100%
(19/21) upgrading python-uc-micro-py                                                [------------------------------------------------] 100%
(20/21) upgrading r                                                                 [------------------------------------------------] 100%
(21/21) upgrading zathura-pdf-mupdf                                                 [------------------------------------------------] 100%
:: Running post-transaction hooks...
( 1/10) Creating system user accounts...
( 2/10) Reloading system manager configuration...
( 3/10) Reloading device manager configuration...
( 4/10) Arming ConditionNeedsUpdate...
( 5/10) Updating the MIME type database...
( 6/10) Updating TeXLive filename database...
( 7/10) Reloading system bus configuration...
( 8/10) Checking which packages need to be rebuilt
( 9/10) Updating the info directory file...
(10/10) Updating the desktop file MIME type cache...

I have tried R and seems to be ok, at least for some basic usage and package loading, so do I need to worries those warnings?

Sys info:
Intel+Nvidia+KDE wayland

I would try reinstalling the package:

sudo pacman -S r

jags-debug was dropped from the AUR. Since it is no longer available in the AUR, attempting to update it led to a “missing package” error, which is to be expected. Having said that, you probably installed jags-debug as a dependency for another package. You can verify this with tools like pactree or simply pacman -Qi jags-debug. If no package requires it and you yourself don’t need it, you can remove jags-debug from your system.

This is just telling you that those packages in the AUR have been flagged out of date.

You should consider updating your mirror list.

1 Like

Thanks!
Reinstalling R gives me no error or warning, and I also reinstalled the mgcv package in R, I assume it is fine then?

1 Like

Thanks!
Indeed I install that as a dependent of jags, but it seems that it is no longer a dependency anymore… so I removed it. :slight_smile:

Not having any warnings or errors is a good sign so I would think it is fine now.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.