Computer crashed mid `sudo pacman -Syu` now pacman doesnt work neither does timeshift

after downgrading everything to march 1st 2024 few days ago using sudo pacman -Syyuu --overwrite "*" everything worked fine and i have resolved what needed to be and decided to come back up to date however my computer crashed mid sudo pacman -Syu and now no matter what i do every single -S command eventually ends in

error: command failed to execute correctly
error: failed to commit transaction (failed to run transaction hooks)

downgrade doesnt work because it uses pacman internally, i built paru from source but it also apparently uses pacman internally so it doesnt work. i am not aware of any alternate package managers i could use and at this point i just want to use timeshift to not have to deal with this however it doesnt work due to

timeshift: symbol lookup error: /usr/lib/libvte-2.91.so.0: undefined symbol: ucnv_toUnicode_74

if one of the mods would be so kind and provided me the mentioned file i d be very grateful
as a last ditch effort i tried building timeshift from source … except guess what? it has dependencies! ones i cannot install (i decided to ignore them and try to build it anyways and got ModuleNotFoundError: No module named 'mesonbuild' so i guess that aint happening)
as of writing this even konsole refuses to launch because

konsole: symbol lookup error: /usr/lib/libkonsoleprivate.so.1: undefined symbol: ubidi_open_74

luckily the one inside dolphin still does work for whatever miraculous reason but i m assuming it wont after a reboot

  1. you could try your luck with pacma-static: https://wiki.archlinux.org/title/Pacman#Using_pacman-static

    Link to download the binary: https://pkgbuild.com/~morganamilo/pacman-static/x86_64/bin/

  2. https://wiki.archlinux.org/title/Pacman#Pacman_crashes_during_an_upgrade

tried 1. (pacman-static) unfortunatelly gave the same error
and 2. tip is regarding crashing pacman which mine isnt, mine computer crashed during update resulting in pacman erroring out… thanks for prompt help regardless
I was thinking of sudo pacman -Rdding timeshift and all its deps recursively (and then installing everything from scratch) since the issue turned out not to happen in every single -S command but only -S commands regarding already installed packages but thought that would be lots of work and in the end found out about and ended up installing grub-btrfs and running grub-mkconfig -o /boot/grub/grub.cfg which resulted in all timeshift entries showing up in grub…
after booting in the correct (working) entry i manually created prior and then trying to restore it i however came across another problem… timeshift seems to restore selected snapshot over currently running one not over the master one resulting in me having to select to boot to this specific snapshot in grub every time i turn on pc