Compositor not working well

Hello everyone!
I have recently gotten Endeavour OS to try learning how to rice properly, and un-commented the following lines in the default i3 config to enable compositing:

exec --no-startup-id xcompmgr -c -C -t-5 -l-5 -r4.2 -o.55 &
exec --no-startup-id picom -CGb

I double checked to install xcompmgr and picom.

However I am having a weird bug with the default xfce4-terminal, in which when I create a new terminal with transparency enabled, sometimes there is a chance that the terminal becomes much darker than it should be, but still transparent, as if its opacity went up from .7 to .8-9 or something. As far as I can tell this is a bug, since when I run mod shift R the transparency reverts back to normal.
Any help?

pick one # out other… no want 2 @ same time

EDit … welcome to endeavouros forum

for ref ( wiki your friend )

" "

" "


you see, I have tried xcompgr on its own by commenting out picom but it doesnt work. And then I tried picom on its own and I can’t log in anymore, not even with tty. It works when I do both. I thought this was because picom is based on compton which is based on xcompmgr??? idk

1 Like

yes that is the reason why it is not enabled per default anymore, depending on GPU and drivers used it can be the one or the other working better, and the options could need to get changed related to that too.

Alright so it doesnt crash when I enable xcompmgr, but there is still quite a bit of that bug from the question. How would I go about changing the settings to fix this?
I’m going to try create an xorg.conf file as it says in the xcompmgr arch wiki

inxi -Fxxc0z --no-host | eos-sendlog

so some not the latest intel GPU, what could need some tweak on xorg settings.
on xcompmgr:

found also this on ArchWiki:
but yours is without Nvidia GPU as i can see?

and intelGPU:

yours will need the xf86-video-intel package, what is installed per default.
But could need at least forcing resolution in grub and enable TearFree option for xorg.

1 Like

Thank you for the first link! I managed to tweak the settings for xcompmgr (simple mode) to look like this

xcompmgr -C -n

instead of the original.
I think the problem was the -o.55 part, since it already sets an opacity. My terminal has its opacity already predefined, so maybe it was some kind of overriding issue im not sure. If anyone would like to let me know why this solves it, please reply thank you! :smiley:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.