Compiling firefox from source

Hi, the first thing I tried after installing endavouros is compiling firefox from source.
But I recieve a weird gpg key error.
I did something like “yay -S arch/firefox-esr”.

How do I get rid of this gpg error ?

Could be:


depending on the error you’re getting.

I did :

pacman -Sy archlinux-keyring ; pacman-key --populate archlinux sudo pacman-key --refresh-keys ; pacman -Syu

$ yay -S firefox-esr
It gave the error :
: There are 3 providers available for firefox-esr:
:: Repository AUR
1) firefox-esr 2) firefox-esr-pt-br-bin 3) firefox-esr68

Enter a number (default=1):
:: Checking for conflicts…
:: Checking for inner conflicts…
Package conflicts found:
-> Installing firefox-esr will remove: firefox
-> Conflicting packages will have to be confirmed manually
[Aur:1] firefox-esr-78.1.0-1

1 firefox-esr (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
:: PKGBUILD up to date, Skipping (1/1): firefox-esr
1 firefox-esr (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
:: (1/1) Parsing SRCINFO: firefox-esr

:: PGP keys need importing:
-> 14F26682D0916CDD81E37B6D61B7B526D98F0353, required by: firefox-esr
==> Import? [Y/n] y
:: Importing keys with gpg…
gpg: keyserver receive failed: General error
problem importing keys

Use a different keyserver. The default keyserver pool on Arch is having issues lately.

nano ~/.gnupg/gpg.conf
add this:
keyserver hkp://
save [Ctrl+X]


I’ve been using for a while since the Arch keyservers started playing up. Seems to have worked so far :joy:

Also, I’ve stuck my keyserver into: /etc/pacman.d/gnupg/gpg.conf

this will only work for pacman, yay is using users keyring :wink:


they are using public keyservers… and what is still failing is the default hkps:// with hkps protocol what is still not working on most all servers from that pool…

Ahh, was wondering why the two conf files! :smiley: