Community Edition ISO Development

Latest ISO for test Community Edition implementation:

Warning not for real use only for testing!!!
https://github.com/endeavouros-team/ISO/releases/download/0-EndeavourOS-development-ISO-releases/endeavouros-devel-2021.03.13-x86_64.iso

https://github.com/endeavouros-team/ISO/releases/download/0-EndeavourOS-development-ISO-releases/endeavouros-devel-2021.03.13-x86_64.iso.sha512sum

6 Likes

This is a TEST!
THIS IS ONLY A TEST!!!

:partying_face:

2 Likes

I downloaded the ISO and trying to install in v-box. It shows no internet connection and won’t install. I cannot click the next button. I tried the regular ISO and is not a problem.


your network is screwed… could be an issue with your Virtualbox?
Is network not working for real or only installer is fault detecting it?

It works on the normal ISO. On this ISO it does not.
Edit: I downloaded it from the other page. Is it the same link?
Edit2: Network is not fast enough? :smile:

Screenshot_2021-03-13 Speedtest by Ookla - The Global Broadband Speed Test

Edit3: The installer is not detecting a network.
Edit: I tried other ISO on Manjaro is working. :man_shrugging:

I did a vbox install yesterday night and I had no issues with network. I had went ahead with the default settings Virtual Box gives for network.

Virtualbox network works fine for me before and after install. Anything specific we should be testing?

Edit: Fwiw, there’s a long delay before reflector-simple comes up after selecting Update Mirrors on the live disk. Works flawlessly once installed.

That’s a known issue, and challenging to solve. The reason is mirror ranking, it is typically very slow because it fetches files from all configured mirrors.

As a workaround, use the reflector app directly, and adjust the option parameters to be more suitable. Especially option --sort with value rate is slow.

3 Likes

can be an issue with drivers / Kernel. Devel ISO has newer versions than both EOS-Release ISO and Manjaro…

1 Like

Mainly the installs of the Community Editions sway and BSPWM from Welcome but also anything not working with the ISO itself, i do currently remove font packages and other stuff to make the ISO smaller.

We do also implement a new way to install Nvidia Drivers from the install if you boot with Nvidia option, so this will need testing to, but if you do not setup paththrough for your vm… it will need install an a system holding a newer Nvidia GPU :wink:

3 Likes

I would like to get the bootlog from LiveSession:
journalctl -b -0 | eos-sendlog

2 Likes

Installed the normal EOS XFCE (online) from this iso to a free partition, not the 2 new editions. Everything went well. By the way, how to get rid of the logout beep sound?

1 Like

It’s not getting a network from the live iso when running the installer in v-box. Everything else i tried works. Trying on bare metal now.

Edit: Just tried it on bare metal and is the same. The installer does not give me any network.

1 Like

Blacklists the pcspkr kernel module
sudo echo "blacklist pcspkr" | tee /etc/modprobe.d/nobeep.conf

2 Likes

then you can copy paste out of the vm and pastebin it:
cat journal.txt | eos-sendlog
What is your network device hardware and driver?

1 Like

I’ll have it for you in a bit. I did an install of bspwm but forgot to grab it. Reinstalling now. Didn’t notice any hard breakage issues.
edit
Inside Installer ENV. At click done button.
BSPWM UEFI, erase disk, swap to file. AMD hardware. 1800x, Vega 64, Sata6 WD Velociraptor 300Gib 10,000 RPM (All other drives are spoken for atm so tossed this in)

journalctl -b -0 | eos-sendlog

http://ix.io/2SOZ

edit2

Inside installed system

http://ix.io/2SP3

I like termite. I like alacritty more. My choice would have been terminator but since it makes sence to keep things uniform and sway and i3 both use thunar and xfce4-terminal makes sense.
I use the middle mouse wheel) click to copy paste in and out of termite. Click to copy click to paste.

2 Likes

the bootlog only if you have hardware related issues, my question was for rick as he has no network on the ISO…

calamares log would be always interesting:
from livesession:
cat ~/endeavour-install.log | eos-sendlog
from installed system:
cat /var/log/Calamares.log | eos-sendlog

1 Like

Installed System. If i do another install i will grab the live session. Actually I am tomorrow on the other machine.

cat /var/log/Calamares.log | eos-sendlog
http://ix.io/2SP4

[ricklinux@eos-xfce ~]$ inxi -N
Network:   Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter driver: wl 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
[ricklinux@eos-xfce ~]$ 

:grin :I get around that by selecting sort=country in the app. Otherwise you can think it has hung… If that gets you slow ones, then go for the sort=rate option ONCE!