Cloud data appeares on one EndeavourOS computer, but not on another

On EndeavourOS 1 the data appeares automatically in the virtual derive, i.e. pCloud Drive, when logged in. On EndeavourOS 2 it doesn’t, that is the problem.

When I choose ‘Open Drive’ from the system tray of pCloud, there are no files or directories on the file manager of EndeavourOS LXQT. I’ve tried by installing pCloud as aur/pcloud-drive 1.9.9-1 as well as your Appimage on EndeavourOS LXQT. (On EndeavourOS pCloud works as expected with aur/pcloud-drive 1.9.9-1, even if aur/pcloud-drive 1.9.9-1 is out-of-date.)

pCloud Drive looks completely empty: no files, directories etc… I’ve tried this with two file managers, i.e. Dolphin and PcManFM-Qt. Same thing with ‘Open Drive’ from the ‘Account’ menu on pCloud Drive. However, when i select ‘my.pCloud.com’ from the ‘Account’ menu on pCloud Drive, it shows data and works as expected.

When I started the desktop app (pCloud Drive) from the Terminal/Console on EndeavourOS 2. The output was as follows:

osVersion → EndeavourOS x64
appVersion → 1.9.9
init failed
Error reading OS release info: Error: Cannot find module ‘…/screen’

As you can see there are error messages.

What I mainly want is that my data from pCloud appeares on virtual drive, i.e. pCloud Drive, on my local computers. I’d like to sync my notes among other things using pCloud between my two EndeavourOS computers.

Could you please propose some ideas how to make pCloud Drive work?

Best regards,

Endear

Welcome @Endear to EOS
I had such problem before.
Here is what I got from pCloud support:

We would like to inform you that we need to delete the following:

  1. /home/@USERNAME/.config/pcloud
  2. /home/@USERNAME/.pcloud
  3. /home/@USERNAME/.config/autostart/pcloud.desktop
  4. all instances of “pcloud” you have downloaded
    /home/downloads/pcloud
    After that please download and install the latest version 1.9.9 from here
    https://www.pcloud.com/download-free-online-cloud-file-storage.html
    Then reboot the machine, log in and re-add the same syncs, if you had any before.

Please let me know if this helps.
Enjoy!

Thank you very much for your reply, limotux!

I’ve got the same answer from pCloud support. Unfortunately, it didn’t help. pCloud support wrote that they’ve given my problem to R&D. So I am trying to get some new ideas here at EndeavourOS forum now.

The virtual derive, i.e. pCloud Drive was empty also on EndeavourOS 1 today.

OMG!!
This is so bad then!
I should congratulate myself for using Koofr as well and syncing both Koofr and pCloud (through pCloud)

I can not understand how come after deleting everything it is supposed to be like you are installing for the first time, so it is supposed to just work!

I don’t know if you tried this, do the same steps of deleting everything, but install pcloud only after you reboot.
I hope this will work.

Let me know please if it worked.
Good luck.

Mission accomplished!

I deleted the following items:
/home/@USERNAME/.config/pcloud
/home/@USERNAME/.pcloud
/home/@USERNAME/.config/autostart/pcloud.desktop
all instances of “pcloud” downloaded, e.g. /home/downloads/pcloud
Sync- and pcloudrive-folder in home directory, among other things.
as well as
I installed pcloud only after rebooting.
Downloaded and installed the latest version 1.9.9 from here

When I rebooted after installing pCloud and logged in to pCloud after rebooting, the pCloud Drive appeared empty.
When I did NOT reboot after installing pCloud, but logged in to pCloud immeadiately after install, the data appeared immediately on the pCloud Drive of EndeavourOS1 and EndeavourOS2.
So rebooting might be a crucial factor.

Thank you very much for your help, limotux!

1 Like

You are more than welcome @Endear
I am glad it worked and I could be of help.
Thank you!

I would suggest you mark the topic as solved.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.