Closing lid does not suspend/sleep the system

Hello all, I recently heard about Endeavour and decided to install it on my Lenovo Flex 3-1120 that was previously running Manjaro Openbox. I’ve enjoyed the experience so far, except I’ve hit something that for some reason I can’t figure out, and it’s probably simple enough that I’ll slap my forehead when it’s finally figured out.
I have the setting enabled to suspend when the laptop lid is closed in the power manager settings, however it does not actually suspend when the lid closes. In addition, when I press the power button the device simply turns off, despite having “Ask” set for all 4 options for buttons. Any ideas as to what I should check here?

Welcome @ajgraves Here is a link to power saving options. Maybe it will help to try some other options.

Thanks @ricklinux for that link, however I don’t believe it was ultimately helpful. What my post was discussing was in the XFCE power settings, nothing to do with TLP or the other option. I will configure TLP at some point, however this is very basic functionality of XFCE at this point that isn’t functioning on the hardware for some reason. It has worked on other distros, though. I have journalctl logs but not sure how helpful they are (and honestly not sure what I’m looking for in this specific instance, however I’m scanning through now seeing if anything jumps out at me).

Here is an XFCE link to power management. You can look run some of these commands and diagnostics.
Maybe it will help figure it out.

https://forum.xfce.org/viewtopic.php?id=11387

For me, i went to the setting editor > xfce-power-manager and unchecked logind-handle-lid-switch. Worked for me.

Brent

1 Like

@Revit I suspect this may be it as I was just looking at the below text in my journalctl log! systemd-logind seems to be receiving the opened/closed event for the lid (and is watching the power button as well). I won’t be able to try until late tonight though as I’m stuck at work without said laptop.

lenny systemd-logind[561]: Lid opened.

@Revit this was ultimately the solution! Works like a charm now. Thanks all :slight_smile: