Chrome and Brave use different file manager when downloading

When I use Brave or Chrome, they are both using a different File Manager than my system default. I am using KDE Plasma and have Dolphin configured as my file manager. It opens something completely different.

The problem with the file manager that Chrome and Brave display is that it doesn’t allow me to rename the file when downloading. It always defaults to a search when I type something new in the filename. Both Chrome and Brave are installed out of AUR. Although I’ve tried Flatpak packages and I think they did the same thing.

So my questions are:

  1. Can I somehow configure these browsers to use Dolphin as a file manager?
  2. If no, can I somehow fix this rename of a file issue so it doesn’t automatically assume I’m searching when I try to rename a filename?


I don’t think you can use dolphin as a file save dialog but you can use the kde file dialog which is probably what you want.

First thing to try is to install kdialog

If that doesn’t work, install xdg-desktop-portal-kde and try running the browser with GTK_USE_PORTAL=1

Thank you for your quick suggestions. I already had kdialog installed so unfortunately that wasn’t a fix. I dind’t have xdg-desktop-portal-kde installed so I installed it. I then opened Konsole and ran brave GTK_USE_PORTAL=1 but I still get the old file manager and the same rename issue I had previously.

It is the opposite:


Thank you. I just tried GTK_USE_PORTAL=1 brave and I get the same file manager behavior. If I right click to “Save Image As”, the file manager is still the one I displayed earlier and I cannot rename the file.

Hmm…I am able to get kde file dialogs in Brave.

I wonder what the difference is.


I am setting GTK_USE_PORTAL=1 in /etc/environment but I wouldn’t think that should be required.

I get the following when running it. Maybe it’s an issue with appmenu-gtk-module?

[user@arch-t470s ~]$ GTK_USE_PORTAL=1 brave Gtk-Message: 11:10:18.450: Failed to load module "appmenu-gtk-module"

It seems likely to be unrelated but I couldn’t say that for sure.

Are you using appmenu/global menus?

My apologies, but I’m not sure how to tell if I’m using appmenu/global menus.

I am fairly certain that functionality is to remove the menus from the application in a similiar fashion as macos.

Do you have other xdg-desktop-portal packages installed? What does this return:

pacman -Qs xdg-desktop-portal
1 Like

It returns

[user@arch-t470s ~]$ pacman -Qs xdg-desktop-portal
local/xdg-desktop-portal 1.14.6-1
Desktop integration portals for sandboxed apps
local/xdg-desktop-portal-gnome 42.3-1
A backend implementation for xdg-desktop-portal for the GNOME desktop environment
local/xdg-desktop-portal-gtk 1.14.0-1
A backend implementation for xdg-desktop-portal using GTK
local/xdg-desktop-portal-kde 5.25.4-1 (plasma)
A backend implementation for xdg-desktop-portal using Qt/KF5

Does anything require xdg-desktop-portal-gnome and xdg-desktop-portal-gtk?

If not, remove them.


Doesn’t let you select the current file name on the name input and type the new file name?

I’m using Chrome from AUR and activates the search box when I start typing after selecting destination folder or clicking outside the name input.

@dalto Thank you for the suggestion. I have removed both xdg-desktop-portal-gnome and xdg-desktop-portal-gtk, closed brave, re-opened it (Just from standard application launcher) and the issue still persists. I have not logged out or restarted yet.

@Triby, if I select the current file name and type any character it immediately takes the keyboard input as search input (switches to search).

Then restart. AFAIK xdg-desktop-portal-* needs restart for activation.

I had this issue once, I think it was on a Wayland session.
Several issues on this subject are affected from session type and environment variables.
Check what you have and try to find some workaround, with the help of Archwiki, starting from this.

Restarting after removing xdg-desktop-portal-gnome and xdg-desktop-portal-gtk did it! Thank you everyone for your help. I now see Dolphin when downloading a file out of these browsers.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.