Changing keyboard layout makes it impossible to switch TTY

I tried switching the keyboard layout for the TTY.

In order to do this, I changed /etc/vconsole.conf to KEYMAP=en. However, if I now switch to a TTY, I can’t use the F keys anymore, they just output A, B, C, etc.

How can I change this, to be a default en-us keyboard layout?

Please have a look here:

You can also switch tty with the command sudo chvt <1-7>

That’s where I got what I have now. I don’t understand what I have to change in order to be able to use my F-keys.

Only on a TTY where I can log in. I can’t on TTY 12, and that is just one keypress away from the KDE hotkey to disable composition… If I accidentally press ctrl+alt+f12, I essentially lock myself out of my computer, and have to hard reset it while loosing all unsaved files.

The KEYMAP variable is used for specifying the keymap. If the variable is empty or not set, the us keymap is used as default value.

Oh. Well, that was easier than I thought. Thanks! I guess, I somehow got confused by the different names than in the x11 keymaps.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.