Certain applications lag by 20-50 seconds

Hello :slight_smile: Installed xfce Endeavour a week ago and it was working fine the first 4 days. Then a number of applications started freezing/lagging on start-up. The ones I’ve noticed are Discord (through Snap), Firefox, the built-in decompressor/compressor in Thunar and when I open links in Discord. All of these things take 20-50 seconds to happen.

So, click a link, wait 20-50 seconds and the link opens. Press “extract here” on a zip, wait 20-50 seconds and the file gets extracted. Start Firefox, wait 20-50 seconds and it starts.

Any ideas?

Snaps in general are super unreliable plus Discord on Linux is a bit iffy. I’d personally use the flatpak version instead. Is Firefox set up through snap also?

Discord is in Arch repo as well: https://archlinux.org/packages/extra/x86_64/discord/

1 Like

No, only Discord is through Snap. Because my arch repo discord installation broke day 2 and I couldn’t be bothered troubleshooting :stuck_out_tongue:

yes, reinstall the system.

1 Like

Is (from memory) xdg-desktop-portal-gnome installed?

No, I checked that already as I found some posts mentioning it :slight_smile:

Not very helpful tbh.

You’re probably going to catch a little bit of flak for using Snaps

Well, they’re welcome to troubleshoot my discord installation then. The snap worked :man_shrugging:. For what it’s worth, I tried Firefox in a flatpak and it had the same issue as local Firefox.

your installation is just a week old. And it was working for the first couple of days. Nothing much to loose with a new installation. And I doubt that a simple update with pacman after 4 days has caused your issue. Best bet in my opinion is a new installation and a thorough observation of all the following customizations and updates.


I would recommend checking the logs to get some pointers on what may be causing your issues. For example:
journalctl -g discord

It might be helpful to see more information about your system. If you could post the urls after running the following commands, I (and I’m sure others) will be happy to delve a little further with you. :slight_smile:

sudo inxi -Fxxc0z | eos-sendlog
sudo journalctl -k -b -0 | eos-sendlog
sudo journalctl -b -0 | grep fail | eos-sendlog
sudo dmesg -rl warn,err,crit | eos-sendlog
sudo pacman -Q | eos-sendlog

That should cover it. :slight_smile:

[jakob@novasuper ~]$ sudo inxi -Fxxc0z | eos-sendlog
[sudo] password for jakob:       
[jakob@novasuper ~]$ sudo journalctl -k -b -0 | eos-sendlog
[jakob@novasuper ~]$ sudo journalctl -b -0 | grep fail | eos-sendlog
[jakob@novasuper ~]$ sudo dmesg -rl warn,err,crit | eos-sendlog
[jakob@novasuper ~]$ sudo pacman -Q | eos-sendlog
Key already exists[jakob@novasuper ~]$

Does this help? :slight_smile:

1 Like

run the pacman one again, but yes that’ll do! :slight_smile:

I tried reinstalling the arch repo version of discord and it seems to work fine in comparison to the Snap version. My firefox and Thunar issues remain tho.

I’m seeing a lot of nVidia issues, and I’m curious to know which version of amd-ucode you have installed. Anything newer than the March release will be problematic until the May/June release is merged.

sudo pacman -Q | eos-sendlog

That’ll answer the amd-ucode question, and also that’ll reveal more about what nvidia packages are installed.

[jakob@novasuper ~]$ sudo pacman -Q | eos-sendlog
[sudo] password for jakob:       
[jakob@novasuper ~]$

I’m running an nvidia GPU with AMD CPU currently. Considering swapping to AMD GPU since I’m now on Linux :slight_smile:

ok yeah first thing right away, downgrade amd-ucode and reboot:

sudo downgrade amd-ucode

Choose the option corresponding to 20230310.xxx or whatever (The March 2023 release). Once completed, reboot, and try things to see if anything improved.

I think the nvidia errors are still a relevant issue that should be resolved, but that amd-ucode thing is DEFINITELY going to eliminate a lot of potential problems right now.

That did not resolve the issue, sadly. Firefox still takes a long time to start. Tried the Flatpak version as well and it has the exact same behavior :thinking: