Cassini neo online installer failing

I’ve previously used the Cassini (non-neo) installer for some VM’s and to a few USB sticks.

Just downloaded Cassini neo and have made a few attempts to install (online installer) to a partition. (btrfs)

Few times failed with pacstrap error, I only uploaded the log for the last one:

pacstrap: error: failed retrieving file ‘linux-6.1.12.arch1-1-x86_64.pkg.tar.zst’ from : Failure writing

Tried once more and there was a different error about not being able to set the label on my partition:

Installing alongside other OS, so I set up partitions manually, selecting the root partition, formatting to btrfs, setting mount point to “/”, selecting efi partition, editing to set mount point to “/boot/efi” but keep content.

Buggy installer or something funny about my hardware or the way I’m trying to set up? I didn’t have a problem with the old Cassini installer, installing to a USB stick, letting it format the whole device.

there is a similar issue at me…
the installer is freezing (at about 35% done the install without any displayed error) ever when try the online install.??
so I do the offline mode and everything is ok

Sounds like a problem with the Arch mirror list.
If that’s the problem, then ranking the mirrors before starting the install might help.

To rank the Arch mirrors, you can use several alternatives:

  • rate-mirrors
  • reflector
  • reflector-simple

Note that to get good mirrors for your location may mean trying those apps one at a time to see if install starts to work OK.

To get help on using them, you can use commands

rate-mirrors --help
reflector --help
eos-apps-info-helper reflector-simple
1 Like

command not found …

sudo pacman -Syu rate-mirrors

error: failed retrieving file ‘linux-6.1.12.arch1-1-x86_64.pkg.tar.zst’ from : Failure writing

It is failing to write to the disk.

Another disk related error.

This would usually indicate either an error in manual partitioning or failing hardware.

1 Like

Also, the partition might be full or not large enough?

This morning, tried some other test installs.

  1. To a VM (Virtual Machine Manager, QEMU/KVM) worked as with previous ISO.

  2. To a 128MB USB stick, allowing installer to use entire device, failed with pacstrap errors.

Several of these:

pacstrap: error: failed retrieving file ‘gcc-libs-12.2.1-2-x86_64.pkg.tar.zst’ from : Failure writing output to destination

I selected btrfs. I can try ext4.

With previous ISO, installs to USB stick worked fine. At least one of those was btrfs.

3 A different OS to a partition (Garuda Wayfire, also btrfs) works fine.

I’ll try updating mirrors, but “Failure writing output to destination” sounds like a local problem. And the fact it worked in a VM, but not just afterward to a partition or a full 128MB USB stick makes me doubt that. But maybe it selected different mirrors.

As far as manual partitioning, I am using the same partitions each time, only choosing reformat root to be sure to clear out previous partial install, and this is on a brand-new device that works for other things (including the Garuda install) so not likely it’s failing already.

I can try the offline install as a test, but it’s not how I want it long-term.

Packages are being downloaded to /var/cache/pacman/package on airootfs, filling it up and failing when it gets to 100% use.

Shouldn’t it download to /var/cache/pacman/package on the target device? It’s not. But it is writing var/log, var/lib, and etc to the target device.

BTW tried install again to partition using ext4 so it’s not related to btrfs. Didn’t think so.

Success. Modified modules/pacstrap/ (I think under /usr/lib/calamares but I’ve rebooted and am not sure) and removed the “-c” option from the pacstrap command.

I suspect that option (use host cache) should have only been used for the offline install, where files are in the iso, but not the online install, where latest versions are downloaded fresh?

Anyway, it got me “unstuck” and I will leave it to the devs to fix it the right way.

BTW this is on a Chromebook with 4GB RAM so it might have worked when tested on a machine with enough ram to download all the packages. (I’m only testing OSs on the Chromebook for a PC I’m building, that one will have 64GB.)

Not sure, though, why the online install worked in a VM, which I’d been giving 2GB.


this one… goot find…