Can't use scanner software (simple-scan, gscan2pdf) without using sudo to open them

I recently got my Brother MFC-9325CW printer/scanner working. Printer works fine with no quirks but the scanner can only be identified if I open the scanning software with sudo admin privileges. Does anybody know a way around this? Is opening an app with sudo a security risk?

I installed these drivers, brscan4 by using debtap to convert the .deb file.

Which groups is your user in? My user for example is in group 96(scanner) and has no issue opening the device.

You can check this for your user with the id command

1 Like

I have a Brother DCP-L2500DW and my user is not in group 96(scanner) and simple-scan works fine.

I would get rid of brscan4 installed with debtap and the .deb file and replace it with
brscan4 from the AUR.

Until you do that, we won’t really know what we are dealing with.


It appears to have sorted it self out after I opened gscan2pdf using sudo. Opened gscan and terminal to get the id info you requested and the scanner is now responding to scan requests. I need to read up on groups/users. Thank you for your assistance.

The user is only in 1 group, there are only 4 other groups, sys, rfkill, wheel, vboxusers. No scanner group and I used the id command with the scanner on and software open. Any idea why I don’t see a scanner or printer group?

I tried the AUR brscan4 and it had the same result. Problem seems to have resolved itself though. Thank you.

1 Like