Can't upgrade the system or install new software

I want to upgrade the system but I get the error

error: failed to prepare transaction (could not satisfy dependencies)
:: installing xorgproto (2019.2-2) breaks dependency ‘dmxproto’ required by libdmx
:: installing xorgproto (2019.2-2) breaks dependency ‘xf86dgaproto’ required by libxxf86dga

I’ve tried to search online and I found that I would need to remove those packets but when I do sudo pacman -R libdmx I get the error

error: failed to prepare transaction (could not satisfy dependencies)
:: removing libdmx breaks dependency ‘libdmx’ required by xorg-xdpyinfo

I get the same errors when I try to install software.

It has to do with an update that needs manual intervention

https://www.archlinux.org/news/xorg-cleanup-requires-manual-intervention/

3 Likes

Thanks!

1 Like