Can't update for the last two days

I got multiple “404” errors from my US mirrors. I tried refreshing them to no avail. I unchecked all US mirrors, checked the box for Canada, refreshed, and updated without incident. The only side effect is now my computer says “eh” all the time.

Is anybody else having trouble with US mirrors? Any update failures? The only change I’ve made recently is I upgraded to AT&T fiber, but it seems to work fine. I don’t see how my fiber upgrade would affect mirror availability. It hasn’t affected any other services except to make them faster.

1 Like

I just updated from Los Angeles. No issues here.

1 Like

All good here(I also have AT&T Fiber).

2 Likes

No issues for me too. On both x64 and ARM.

1 Like

Here you can Check From all mirrors the Status:

https://archlinux.org/mirrors/status/

2 Likes

No problems here in the French Caribbean with a ratty 925Kbs :sleeping: :zzz:
connection, and still got no errors updating with US and Canadian servers.

1 Like

I upgraded to KDE 5.25 this morning from the US mirrors.

Why not have a try with Worldwide mirror ? Sometimes going with this can may fix the issue. I had did this in the past.

I have no problem with my daily desktop. I updated without any problems today. There have been times when I have had to change a mirror, but this is not common. Sometimes it happens on my laptop that I can’t update the packages at first, but this is the second time the operation is usually successful. True, I use mobile internet on it.

In France, we have some operators that are blocking some website, we have to “force” some DNS server to resolve it.
Mainly it’s for blocking some downloading “illegal” websites. Never had the problem for updating.

Maybe AT&T do the same? So try with another DNS, it could resolve the problem.

You could experiment with reflector options. Something like

# reflector --latest 10 --sort rate --country US,CA --save /etc/pacman.d/mirrorlist

If that doesn’t give a working mirrorlist, then try adding option --age with a small number, e.g. from 2 to 5.

This is what finally worked for me. Remember we usually have around 2mbps down and .4 upload, on a good day. It’s supposed to be 20mbps :rofl:

sudo reflector -c USA -c CA -a 5 -n 20 -l 10 -p https --verbose --sort rate --download-timeout 60 --save /etc/pacman.d/mirrorlist

Here is the whole process.

[michael@eos-22 ~]$ sudo reflector -c USA -c CA -a 5 -n 20 -l 10 -p https --verbose --sort rate --download-timeout 60 --save /etc/pacman.d/mirrorlist
[sudo] password for michael:
[2022-06-17 06:59:36] INFO: rating 5 mirror(s) by download speed
[2022-06-17 06:59:36] INFO: Server Rate Time
[2022-06-17 06:59:45] INFO: https://mirror.sergal.org/archlinux/ 811.21 KiB/s 8.43 s
[2022-06-17 06:59:55] INFO: https://mirror.scd31.com/arch/ 692.93 KiB/s 9.87 s
[2022-06-17 07:00:04] INFO: https://mirror.powerfly.ca/archlinux/ 809.16 KiB/s 8.45 s
[2022-06-17 07:00:12] INFO: https://mirror.xenyth.net/archlinux/ 932.50 KiB/s 7.34 s
[2022-06-17 07:00:21] INFO: https://muug.ca/mirror/archlinux/ 902.09 KiB/s 7.58 s
[michael@eos-22 ~]$ cat /etc/pacman.d/mirrorlist

Arch Linux mirrorlist generated by Reflector #################

With: reflector -c USA -c CA -a 5 -n 20 -l 10 -p https --verbose --sort rate --download-timeout 60 --save /etc/pacman.d/mirrorlist
When: 2022-06-17 11:00:21 UTC
From: https://archlinux.org/mirrors/status/json/
Retrieved: 2022-06-17 10:59:36 UTC
Last Check: 2022-06-17 10:46:48 UTC

Server = https://mirror.xenyth.net/archlinux/$repo/os/$arch
Server = https://muug.ca/mirror/archlinux/$repo/os/$arch
Server = https://mirror.sergal.org/archlinux/$repo/os/$arch
Server = https://mirror.powerfly.ca/archlinux/$repo/os/$arch
Server = https://mirror.scd31.com/arch/$repo/os/$arch

Now your all mirrors are from Canada.

The reason is your command line, it doesn’t search mirrors from the United States because you used option -c USA which should be -c US

1 Like

Thanks for the correction.

Just in case you are using wifi, can you try plugging into the Ethernet port and then re-run reflector?

The reason I am mentioning this is recently on one of my laptops the Broadcom wifi failed in an odd way. So I could connect to wireless but then it would not download any faster then 1.5 mbps. So the past couple of months I have had mirror issues with that computer.

Sorry.

Is reflector updating the mirrors now?

Did any of these posts work?

I am interested to know if it is or was a connectivity issue or reflector options?

It’s on wired Ethernet. I’m not plugging AT&T fiber but: 250Mb/s for WiFi devices and 350Mb/s for wired devices. I’m on the 300Mb/s plan. They haven’t buried it yet. The fiber is strung across my lawn. Looks like skinny 2-conductor speaker wire.