Can't start modem-manager-gui with simcard on

My hardware info
My boot log
My modem is huawei MegaFon M150-2, Modem Manager Gui ver. 0.0.20
My system is Endeavour OS Build 2021 08 27, XFCE.
I have very little linux experience and understanding… :sweat_smile:

Yesterday, Modem Manager gui work just fine with no problem. Today I updated the system, then I realize that I can’t launch Modem Manager Gui when I click the icon app. So I try to remove and reinstalled the app, the problem is still persist.

This time I try sudo modem-manager-gui, the app showed the welcome screen, but after selecting modem manager and network manager type and pressing continue, the app crashed again.

So here’s what I found,

  1. While modem is disconnected:
  • Clicking the icon app, the app is able to launch without any error
  • When I use sudo modem-manager-gui, the app is also able to launch, and these show up in the terminal:
Connection manager: Network Manager >= 0.9.0
Modem manager: Modem Manager >= 0.7.0
(modem-manager-gui:3636): libnotify-WARNING **: 13:57:12.333: Failed to connect to proxy
(modem-manager-gui:3636): GLib-CRITICAL **: 13:57:12.334: g_strrstr: assertion 'haystack != NULL' failed

I tried connecting the modem with no sim card on the slot, and try to relaunch the app. App can launch, and the same warning appeared when I use sudo modem-manager-gui.

  1. While modem is connected (with simcard on the slot):
  • Clicking the icon app does nothing.
  • When I use sudo modem-manager-gui, these show up:
Connection manager: Network Manager >= 0.9.0
Modem manager: Modem Manager >= 0.7.0
(modem-manager-gui:3038): libnotify-WARNING **: 13:44:22.234: Failed to connect to proxy
(modem-manager-gui:3038): GLib-CRITICAL **: 13:44:22.234: g_strrstr: assertion 'haystack != NULL' failed
Segmentation fault at address: 0x20
Stack trace:
1. /usr/lib/ [0x7fb7787edad0]
2. /usr/lib/ [0x7fb7787edad0]
3. /usr/lib/ [0x7fb7788699ee]
4. /usr/lib/modem-manager-gui/modules/ [0x7fb771a2d792]
5. modem-manager-gui(mmguicore_connections_enum+0x6f) [0x5613e1399d9f]
6. modem-manager-gui(+0x4942a) [0x5613e13ba42a]
7. modem-manager-gui(mmguicore_devices_open+0x1c5) [0x5613e139a395]
8. modem-manager-gui(+0x3af15) [0x5613e13abf15]
9. modem-manager-gui(+0x4902b) [0x5613e13ba02b]

Things I have tried to fix the problem:

  • Remove and reinstall modem-manager-gui from the repo.
  • Installed modem-manager from the repo.
  • Restart and Shutdown the system.

I tried googling around and tried this:

  • Checking if there’s sms stuck on the sim and removing it using mmcli -m any --messaging-delete-sms=/org/freedesktop/ModemManager1/SMS/.
  • Removing sms using mv ~/.local/share/modem-manager-gui ~/.local/share/modem-manager-gui.old.
  • Remove and reinstall modem-manager-gui from the repo again.
  • Try to update the system using sudo pacman Syu.

The problem still persist. Any help will be appreciated. Maybe anyone knows a keyword to search around for the fix (since I don’t even understand what’s preventing the app to launch with sim card on haha).

Thank you.

First, I’m not using modem-manager-gui so cannot verify anything said below.

I assume this is a compatibility problem with a recent update.
Seems that networkmanager was recently upgraded. Downgrading it may temporarily help, but note that downgrading is not a long term solution, and may cause other issues.

To downgrade, run command

sudo downgrade networkmanager

and select the previous version.
Then reboot.

If that works, you can temporarily disable upgrades to this package by adding line

IgnorePkg = networkmanager

into file /etc/pacman.conf.

1 Like

Thank you for this, it works!

Downgrade networkmanager to 1.32.12 and Modem Manager Gui can connect again with simcard on the slot. Though when I do sudo modem-manager-gui, the libnotify-warning and GLib-CRITICAL still persist.

For now, this is good enough. Thank you again~


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.