Can't see CD-Rom anymore

Well, this is embarrassing. My CD-ROM has disappeared.

cdrecord dev=/dev/sr0 -checkdrive
Cdrecord-ProDVD-ProBD-Clone 3.02a09 (x86_64-unknown-linux-gnu) Copyright (C) 1995-2016 Joerg Schilling
scsidev: '/dev/sr0'
devname: '/dev/sr0'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
cdrecord: No such file or directory. Cannot open '/dev/sr0'. Cannot open or use SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

$ lsblk -f
NAME   FSTYPE FSVER LABEL       UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
sda                                                                                 
├─sda1 ext4   1.0   endeavouros c867ae29-f90a-4627-ba48-1c862a789840    1.1T    33% /
└─sda2 swap   1     swap        c5c0c01b-ea17-47e0-b3e9-64ac97fe78dc                [SWAP]
sdb                                                                                 
└─sdb1 ext4   1.0               fce77abc-61bd-4fab-a5c2-be0a805a684f                
sdc                                                                                 
└─sdc1 ext4   1.0   bckp        c0d70229-21c0-45ed-8398-ab79b61180a4 

Any suggestion would help. I’m not command prompt very savvy, but happy to learn. Thanks!

Check if the kernel module is loaded:

lsmod | grep sr_mod

If no output, try loading it manually:

sudo modprobe sr_mod

See if the device shows up.

Thanks!

Tried it and no output.

Manually loaded and it gave me this message: libkmod: kmod_config_parse: /etc/modprobe.d/usbcore.conf line 2: ignoring bad line starting with ‘mw’

I’m guessing I need to look into usbcore.conf and see what that offending ‘mw’ is?

Thanks for your help

I removed the ‘mw’ from usbcore.conf and typed lsmod | grep sr_mod yielded

sr_mod                 28672  0
cdrom                  86016  1 sr_mod

I still don’t see the drive. K3B can’t find it either.

The only thing inside usbcore.conf is: options usbcore autosuspend=-1 #prevent USB auto-suspend for new USB devices

1 Like

Faulty cable!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.