Can't run Pi4 (ARM) Installer


I tried flashing Pi4 image on my SSD all I get is desktop with 3 planets I double click to launch Calamares nothing happens sits there doing nothing … Same with all apps… Nothing runs…

I tried via Artemis ISO, then script from Github same result… I get to desktop Calamares refuses to run…

Any help would be greatly appreciated…

1 Like

Here is the official method for installing EndeavourOS on a RPi 4

On a operational x86_64 computer, boot into the Artemis nova liveISO. On the first screen, choose

EndeavourOS ARM Image Installer

The next screen will display some information. After Reading, and ensuring a storage device is connected to a USB port to install to, click on

Start ARM Installer

Then answer the questions and the Official EndeavourOS image will be installed.

Next, connect the storage device to your RPi 4 and boot up.

Calamares should come up and walk you through the configuration setup.

If you have followed this, and it still doesn’t work, we need more info

Are you using a micro SD or a USB SSD for your storage device?

How old is your RPi 4? The hardware Version number for your Pi would be helpful. It could be Ver 1.x - Ver 2.0 - Ver 4.0 or Ver. 4.1 The harware Ver would be important if installing to a USB SSD.


To reply to all, I followed offical guides, as mentioned above… Nothing worked. My Pi is series 1.2 with bootloadfer from this month updated today via official PiOS… Flashing on brand new 120gb SSD (Biostar) Nothing is running I don’t see calamares nothing …

I can boot Manjaro Arm, PiOS, and many other Distros just fine…

Click to see issue

1 Like

You are doing everything right, and the installation of the image is working. But Calamares should just come up by itself after a brief delay.

Let me do a test install and see if I can re-create this problem.
Chat with you soon.


I even tried the script method, git cloned images github ran the script let it download and flash the image… I just edited it so it doesn’t delete it after it’s done to save bandwidth as am on severely capped net… Successfully flashed but same issue I get to desktop nothing works… Sometimes I get a YAD with 3 options other times nothing …

Used this

1 Like

how much RAM is the pi holding in?

One last question, did you choose ext4 or btrfs file system during image install?

Okay, I did an install with ext4 and everything went as expected.

In the white box, If you want to edit the mirrorlist do so first.
Then click if you want to install a Official Edition or Community Edition.
Official edition is all the Desktop Environments plus i3wm
Community edition is Community supported Window Managers.
Then Calamares should come up.

Where to start with your problem.
If you installed with btrfs you could try a ext4 install. Although I don’t think that is the problem since the image actually booted.

For troubleshooting purposes, if you have a spare micro SD, you can try to install to a micro SD. The storage device is much more likely the problem. Also, what device are you using for the USB SSD enclosure. I have found that the USB 3 to SSD enclosure can cause problems. Some enclosures are great, some not so much.

I usually run Samsung SSDs, but recently I bought an Adata 256 GB SSD for testing.
For this test , I used the Adata in this enclosure:

The only other thing I can think of, when the liveISO boots up into XFCE4, there is a rotating circle right next to the mouse cursor. I always wait until that rotating circle goes away before doing anything. The reason the circle is there is because the OS is still doing stuff in the background, so I wait for it to go away. But I don’t think that is the problem here either

Let us know what you try and how it turns out.


Joe makes a good point. If your RPi 4 is a 2 GB RAM model, that maybe too little RAM for Calamares. Calamares uses a lot of memory. We have had problems in the past with people trying to install EnOS to a Mac or other notebooks and 2 GB RAM is a problem.


4GB Pi4


EXT4 I chose for FS… In the YAD dialog whatever I click nothing happens… No error, zero feedback… I tried on 2 SSDs, 3 microSD cards, 2 USB sticks… Am running out of places to flash to lol… And I waited for all loading circles to go away… Safely ejected all devices… I am about to give up n flash Manjaro XFCE since it works just fine so do all other Arm distros I flashed… Only EOS is acting up…

1 Like

I use the cheapest Keyboard that Amazon had, likewise for the mouse, that I use on my testing machine. I was trying to go frugal on the test setup. To the point, with both my RPi 4 and Odroid N2, I have to always unplug and re-connect the keyboard on a cold boot on the test rig. Quite often I also have to unplug and re-connect the mouse, also only on a cold boot. Both are fine after a reboot. After that I am out of ideas.

Your hardware and current EEPROM firmware version should work.
You have covered all the bases. I will have to ponder on this a while.
Also, when @sradjoker gets back from vacation, I will see what he thinks.


Sorry for all the problems. From what I have seen, you are quite knowledgeable about Linux and ARM devices, so I hope to see you around the Forum.


I have my own x86 Distro XeroLinux… I dunno how to convert to Arm way above my head… I just wanted my “Sister” distro on my Pi4 :wink:

1 Like

:pray: forgive push in . I never use this installer before but i confirm @Pudge the installer work on my Rpi4 ( SD only ) i no have free ssd .
EDit i just finish , it boot/work ok
@TechXero :pray: you have bad xp on try install . strange for sure

1 Like

I just remembered something, I do not know what’s wrong with my Pi4 but everything I flash on SD cards fails to boot correctly the only way I can get any OS to bottis is by using the NesPi 4 case’s SSD bay (SATA) even USBs either result in black screen or a message saying block size mismatch or something like that… Strange never had any issues before today… Dying Pi4 ? Could be… Been sitting in my shop gathering dust since 2021…

Flashing on SD Card

It is a good idea to check Calamares logs. Try launching Calamares from the commandline. I don’t know if EndeavourOS uses a launch script, but you may try sudo calamares -D8

Excuse me but what part of nothing runs wasn’t clear ? Nothing opens not terminal not calamares nothing not even app menu or whatever it’s called… I can barely right click on desktop …

Ctrl Alt F3 for tty and check systemd logs perhaps?

You can use an external SSD and flash the Arm image by connecting to another computer. Then see if it boots on the Pi and run install from there. Or have you tried that already?

Thanks but I gave up now Pi is gathering dust as usual… Everything worked on it except EOS… So called it there… Sorry… I hate that thing is slow not made for desktop OS… Maybe one day will find a use for it…

Done that in SSD and card to no avail… Anyway read above