Cant login after update

I now do not automatically log in and on entering my password it just loops back to the login screen after a few seconds

I used yay to update system earlier and it updated something keyring - could be relevant?

There could be several reasons why this is happening.

First, switch to a TTY and run a full sudo pacman -Syu again to make sure the system is fully up-to-date. There is more detail and further options for this step under [FAQ] Computer doesn’t boot, boots to a black screen, or stops at a message

Then, sudo chown -R $USER $HOME to make sure file and directory permissions are correct.

If neither of these steps work then you’ll need to find some log files to determine what is preventing login, but the steps above are a good starting point.

Thanks @jonathon
I tried:

sudo pacman -Syyu
and then sudo chown -R $USER %HOME

bot no luck - same thing on reboot I get the login window (that I normally have autologin to bypass) and putting in my password (that still works for a TTY) just gives me a black screen with cursor for a few seconds then back to login window

Then I tried start x and I get three terminal windows, one of which I typed firefox into and here I am replying…

Firefox menus flash up but dont ‘stick’

Now working out how to exit firefox and reboot :smiley:

I am on i3
I read somewhere that I should startx then i3-config-wizard
Edit: it was here
after renaming my config to config.bak and then running i3-config-wizard I am back into i3
So it must be something in my (modified) config file I guess
Do you know where that could be to stop i3 starting and getting the behaviour that I had, please?

I realised finally that this was i3 not starting and looked in that part of the forum and found the post about picom

when I commented out that line I am back in

Now to understand what I did what picom is and how to get things working ‘normally again’ which I will do on the i3 part

Thanks for your help!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.