Can't login after reboot just after install EOS

I’m initially able to login to EOS but after a few required reboots I’m to longer able to login. I get the login screen but when I select my username and enter the password I just get a blank screen then the login screen again. I’m not able to get any further. Tried reinstalling EOS but the same problem occurs. I’ve done numerous Google searches to no avail.
Any suggestions? Thanks in advance.

What requires rebooting? What are you changing between installation and when the problem occurs?

I have the computer disk partitioned. When I cold boot I select the EndevourOS partition to boot into. I have Linux Mint on the other partition. I just set up the EndevourOS partition on the disk space I freed up at install. I was able to install the OS without a problem. Several updates to the system require reboots. After a few reboots I get stuck at login. It doesn’t reject my password, it just keeps going back to asking for my username and password. I tried entering an incorrect password just for grins and it does give the message that the password is incorrect.

That provide a little extra context, but you didn’t answer the main question of what was changed just before the problem started.

Specifically, what change did you make, or which packages did you update, before the final reboot when you can’t log in.

You might also want to provide inxi -Faz to give people some idea about what hardware you’re using.

and some more basic info on what Desktop is in use and how install is setup.


I believe this is what was asked for. To sum up. It’s a Dell Inspiron 15" notebook computer. The only thing I did was add was Libre Office and did a system ugrade. The system told me I needed to reboot after the system uograde. I hope I didn’t leave anything out. I’m used to solving problems on my own. I only once before asked a question in a forum

inxi -Faz
richard@richard-Inspiron-15-5501:~$ inxi -Faz
System:    Kernel: 5.4.0-90-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.4.0-90-generic root=UUID=81de2b03-8c7f-4aa0-9191-893e26986bb9 ro quiet splash 
           Desktop: Gnome 3.36.9 info: i3bar wm: i3 4.17.1 dm: LightDM 1.30.0 Distro: Linux Mint 20.2 Uma 
           base: Ubuntu 20.04 focal 
Machine:   Type: Laptop System: Dell product: Inspiron 15 5501 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 07GGFN v: A00 serial: <filter> UEFI: Dell v: 1.3.0 date: 05/20/2020 
Battery:   ID-1: BAT0 charge: 54.2 Wh condition: 54.2/53.0 Wh (102%) volts: 16.8/15.0 model: SMP DELL 9077G06 type: Li-poly 
           serial: <filter> status: Full 
CPU:       Topology: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP arch: Ice Lake family: 6 model-id: 7E (126) 
           stepping: 5 microcode: A6 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19046 
           Speed: 3473 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 3521 2: 3203 3: 3223 4: 3429 5: 3532 6: 3086 7: 3409 
           8: 3227 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:8a56 
           Display: x11 server: X.Org 1.20.11 driver: modesetting unloaded: fbdev,vesa resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 21.0.3 direct render: Yes 
Audio:     Device-1: Intel Smart Sound Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:34c8 
           Sound Server: ALSA v: k5.4.0-90-generic 
Network:   Device-1: Intel Killer Wi-Fi 6 AX1650i 160MHz Wireless Network Adapter driver: iwlwifi v: kernel port: 3000 
           bus ID: 00:14.3 chip ID: 8086:34f0 
           IF: wlp0s20f3 state: up mac: <filter> 
           IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter> 
           IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 536.10 GiB used: 150.78 GiB (28.1%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: BC511 NVMe 512GB size: 476.94 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 11001101 scheme: GPT 
           ID-2: /dev/sda type: USB vendor: SanDisk model: Cruzer Glide 3.0 size: 59.16 GiB block size: physical: 512 B 
           logical: 512 B serial: <filter> rev: 1.00 scheme: GPT 
Partition: ID-1: / raw size: 370.68 GiB size: 363.86 GiB (98.16%) used: 150.77 GiB (41.4%) fs: ext4 dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 66.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 3314 
Info:      Processes: 322 Uptime: 14h 06m Memory: 7.55 GiB used: 3.71 GiB (49.1%) Init: systemd v: 245 runlevel: 5 Compilers: 
           gcc: 9.3.0 alt: 9 Shell: bash v: 5.0.17 running in: gnome-terminal inxi: 3.0.38

does not look like EOS :wink:
So what was the Desktop installed on EndeavourOS ? and how do you setup partitions ma yuse encryption? BTRFS ? what ISO release?

1 Like

Strange. In the past I tried reinstalling EOS several times and encountered the same problem. This time after a few failed attempts - getting "failed to synchronize databases, there is nothing to do, I was able to do the system upgrade. I rebooted a couple of times and now I’m always able to login. Any idea what could have changed.? I did choose GDM as the environment both before and just now. I did absolutely nothing different AFAIK.

That question can only be answered by you. What did you change?

And as noted so far all we know is you have Linux mint installed (fantastic distro btw,I love it).

You could always chroot into your EOS run passwrd and enter your user name and create a new password. . .

And what packages were updated during that upgrade?

(Hint: Look in /var/log/pacman.log)

I’m actually having a similar issue as well. I’m not sure what caused it, but as a temporary fix I found that if you click on your profile to login, and then click on the gear in the bottom right, and reselect your DE you can log in.