Can't load endeavour after changing power supplies

Hello once again, I am using an Asus z97-a motherboard with an m2 installed on it. I had endeavour running well; then was getting a power surge indication from the bios so I exchanged it for a new one and no more problems getting past the bios.
From there the problem began. I had previously had the Atlantis version OS on the nvme mounted on the motherboard. So I thought it would still boot from there. I get the Asus bios screen then next screen I get the grub loading… Welcome to Grub screen! It then goes to the endeavour loading options (on linux-its, fallback intramfs, linux, fallback). I’ve tried all four selections and it goes back to the loading options screen.
After trying that a few more times; now I get-
Error: no such device:c834c4c1-2ded-4333-9c25-19606065411ab5
error disk`hdo,msdos1’ not found. press any key to continue.
then it does back to the loading options screen.
The only thing I think I could have possibly messed up was the order I reconnected the other five ssds as storage.
Anybody help please.

You will need to make sure the SSD’s are in the same order prior to taking apart your computer. Depending on how the system was setup in the first place - it could matter.

OR you’ll need to chroot and reinstall grub so it knows where to find your system.

And depending how you have your system/ssd’s setup - you may need to rebuild your fstab. It would be a lot easier to just get your ssd’s in the correct order.

This shouldn’t matter.
My bet goes with BIOS settings, as they have probably been reset. Configure again and confirm no RAID is enabled (set to AHCI).

Ok I’ll play around until I get them right. Don’t have any experience with chroot.

Pre-emptively because I know the next questions:

Reinstall/rebuild grub:

Everything you need to know about fstab:

1 Like

Also make sure secure boot is off.


And double-check that your cables are seated firmly.

1 Like

chroot is very easy. It’s a beginner level Arch procedure. EVERYONE who uses Endeavour should know how to at least chroot.

I’ll check them all.
Thank you all.

The only screens I get are the afore mentioned above in my first post ; so how can I otherwise get into the terminal?

set to other os.

cables are all secure.


That was the indicator that lead to me to the fstab.

Tried both chroot and fstab on live user after I tried to start the installer.
When I try to restart the installer, so I can tell you why it said the installation failed the first time, I get to the page to partition the drive and it will only let me create, edit or delete the existing partition which I believe is correct as it is. So looking at the options I am left with under edit, it wants me to pick a mount point. Either: /, /boot, /home, /opt, /srv, /usr or /var.

sudo fdisk -l shows on the first device : /dev/nvme0n1pl
Boot Start End Sectors Size Id Type

  •    2048       488392064    488390017   232.9G    83   linux 

all the other mounted disk info:
Disk /dev/sda, dev/sdb, dev/sdc and dev/sdd are all identical:
Disk model: Samsung SSD PM84
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimal/optimal): 512 bytes / 512 bytes

Disk /dev/sde: 1.82 Tib, 2000398934016 bytes, 39037029168 sectors
Disk model: ST2000LM007-1R81
Units: sectors of 1 * 512= 512
Sector size (logical/physical): 512 bytes / 4096
I/O size (minimal/optimal): 4096 bytes /4096 bytes

Disk /dev/sdf: 14.9 Gib, 16008609792 bytes, 31266816 sectors
Disk model: Cruiser Glide
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimal/optimal): 512 bytes / 512 bytes
DiskLabel type: Dos
Disk identifier: 0x6abbeac5

Device Boot Start End Sectors Size Id Type
/dev/sdf1 * 64 3742559 3742496 1.8G 0 Empty
/dev/sdf2 37422560 3951455 20886 102m ef EFI (FAT-12/16/32)

Disk /dev/loop0: 1.68 Gib, 1808896000 bytes, 3533000 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimal/optimal): 512 bytes / 512 bytes

so I tried:
#mount: /dev/nvme0n1 /mnt
returns:mount: /mnt: /dev/nvme0n1 already mounted or mount point already busy
sudo fstab -l
#arch-chroot mnt
Can’t create chroot on non-directory mnt
Sorry for the long text. I really don’t know what I am doing.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.