Can't launch a game on Xorg

Hey new EOS user here. i can’t launch a game(CSGO) on Xorg. i tried xfce, kde and gnome. with kde the game didn’t work at all i got 10-20 fps then the whole sys log me off. with xfce i got to open the game and play it even tho my performance on other distros was better. with gnome Wayland it works but kinda laggy with gnome Xorg once the game is launched the whole sys log me off.
what do u think the problem is and how to fix it i assume its Xorg on gnome as Wayland works (kinda) but im not sure if its something else.

I’ve installed these on every DE i tried

sudo pacman -S lib32-mesa vulkan-radeon lib32-vulkan-radeon vulkan-icd-loader lib32-vulkan-icd-loader -y

How are you trying to launch it? Are you trying to run the linux version or the windows version?

linux version. tried it from steam itself and using lutris

Are you using steam-native or steam-runtime?

Can we see the output of inxi -Fxxxz

i did

pacman -S steam

so it gave me steam-runtime

and Here

System:
  Kernel: 5.12.10-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm4 vt: 7 
  dm: LightDM 1.30.0 Distro: EndeavourOS base: Arch Linux 
Machine:
  Type: Laptop System: LENOVO product: 20351 v: Lenovo G50-70 
  serial: <filter> Chassis: type: 10 v: Lenovo G50-70 serial: <filter> 
  Mobo: LENOVO model: Lancer 5A2 v: NANANANANO DPK serial: <filter> 
  UEFI: LENOVO v: 9ACN32WW date: 07/20/2015 
Battery:
  ID-1: BAT0 charge: 10.9 Wh (100.0%) condition: 10.9/28.5 Wh (38.4%) 
  volts: 16.2 min: 14.4 model: Lenovo IdeaPad type: Unknown serial: <filter> 
  status: Full 
CPU:
  Info: Dual Core model: Intel Core i7-4510U bits: 64 type: MT MCP 
  arch: Haswell rev: 1 cache: L2: 4 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 20759 
  Speed: 798 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 798 2: 1987 
  3: 1995 4: 1049 
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Lenovo 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0a16 class-ID: 0300 
  Device-2: AMD Sun LE [Radeon HD 8550M / R5 M230] vendor: Lenovo 
  driver: radeon v: kernel bus-ID: 03:00.0 chip-ID: 1002:666f class-ID: 0380 
  Device-3: Acer Lenovo EasyCamera type: USB driver: uvcvideo bus-ID: 2-6:3 
  chip-ID: 5986:055d class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.org 1.20.11 driver: loaded: ati,intel,radeon 
  unloaded: fbdev,modesetting,vesa resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) 
  v: 4.5 Mesa 21.1.2 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Haswell-ULT HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403 
  Device-2: Intel 8 Series HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403 
  Sound Server-1: ALSA v: k5.12.10-arch1-1 running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.30 running: no 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: 4000 bus-ID: 01:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: Lenovo driver: ath9k v: kernel port: 4000 bus-ID: 02:00.0 
  chip-ID: 168c:0036 class-ID: 0280 
  IF: wlan0 state: down mac: <filter> 
Bluetooth:
  Device-1: Qualcomm Atheros AR3012 Bluetooth 4.0 type: USB driver: btusb 
  v: 0.8 bus-ID: 2-7:5 chip-ID: 0cf3:3004 class-ID: e001 
  Report: bt-service: disabled note: bt-adapter can't run. 
Drives:
  Local Storage: total: 931.51 GiB used: 34.32 GiB (3.7%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10JPCX-24UE4T0 
  size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> 
  rev: 1A01 scheme: GPT 
Partition:
  ID-1: / size: 906.66 GiB used: 34.32 GiB (3.8%) fs: ext4 dev: /dev/sda2 
  ID-2: /boot/efi size: 511 MiB used: 280 KiB (0.1%) fs: vfat dev: /dev/sda1 
Swap:
  ID-1: swap-1 type: partition size: 8.8 GiB used: 1.8 MiB (0.0%) 
  priority: -2 dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 46.0 C mobo: N/A gpu: radeon temp: 40.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 182 Uptime: 2h 23m wakeups: 1 Memory: 7.66 GiB 
  used: 2.18 GiB (28.5%) Init: systemd v: 248 Compilers: gcc: 11.1.0 
  Packages: pacman: 924 Shell: Bash v: 5.1.8 running-in: xfce4-terminal 
  inxi: 3.3.03 

Whoa, a 6+ year old hybrid intel/amd machine. That is a bit out of my expertise.

That being said, if you haven’t already set it up you will need some kind of setup to switch between your integrated and dedicated GPUs. I am not sure how that used to be done with intel/radeon. Hopefully someone better versed in your hardware will come along.

1- i did launch the game with dedicated GPU
2- why other distros give me better performance with the same game and same settings or they just tweak it somehow

Thank you for your time.

What are you using to switch in that setup?

To be clear, I wasn’t implying that your hardware can’t run the game. Just that your setup is one that I am not familiar enough with to help.

I am sure it is possible for it to perform just as well on EOS, you just need someone else to help you with that. :slightly_smiling_face:

from lutris itself u can chose to run the game on dedicated GPU
ik my hardware is so old but it is what it is.
and to be fair here EOS in general perform WAY too good on my laptop its so fast so smooth i really like it gave my old laptop a new life the only problem i have is that gaming problem

Are you sure it works with your setup?

i tried that and DRI_PRIME=1 in steam both didnt solve my problem on EOS