Can't install systemd-boot

Hello. I am trying to replace grub with systemd-boot.
When installing endeavour i chose btrfs as the filesystem. I saw another post in the forum but i don’t know what i am missing. Please help me.

My config files are:

/boot/efi/loader/loader.conf

default endeavour.conf
timeout 5
console-mode max
editor no

/boot/efi/loader/endeavour.conf

title   EndeavourOS
linux   /vmlinuz-linux
initrd  /amd-ucode.img
initrd  /initramfs-linux.img
options root=UUID="348207ca-14fb-4c45-8caa-e4929f493356" rootflags=subvol=@ rw

Content from lsblk:

NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
nvme0n1     259:0    0 476,9G  0 disk 
├─nvme0n1p1 259:1    0   300M  0 part /boot/efi
└─nvme0n1p2 259:2    0 476,6G  0 part /var/log
                                      /var/cache
                                      /home
                                      /

Content from ls /boot:

amd-ucode.img  grub                          initramfs-linux.img               initramfs-linux-lts.img  vmlinuz-linux
efi            initramfs-linux-fallback.img  initramfs-linux-lts-fallback.img  loader                   vmlinuz-linux-lts

And the result from sudo bootctl list

Boot Loader Entries:
        title: EndeavourOS (default)
           id: endeavour.conf
       source: /boot/efi/loader/entries/endeavour.conf
        linux: /vmlinuz-linux (No such file or directory)
       initrd: /amd-ucode.img (No such file or directory)
               /initramfs-linux.img (No such file or directory)
      options: root=UUID="348207ca-14fb-4c45-8caa-e4929f493356" rootflags=subvol=@ rw

When i reboot it only shows me an option too boot to the BIOS. What am i doing wrong?

Please refer to this tutorial written by @dalto:

You need to make a new directory /efi and mount your ESP partition there. It all is explained in the the tutorial.

1 Like

Thanks. Everything went smoothly.

1 Like

Sounds great!
Glad you got it working!
:enos_flag:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.