Cant install rstudio (yaytmp-1000 doesnt exists)

Hello im trying ti install rstudio from here:

The issue is that when I clone the repository , I got a file where there a commented line specifying the following:

make all required packages available in pkg-cache, e.g. like this:

mkdir pkg-cache
yay -S r-testthat
mv /tmp/yaytmp-1000//.pkg.tar.xz pkg-cache/

when I create the pkg-cache/ directory under r-studio-desktop/ directory, I try to move the mentioned path “mv /tmp/yaytmp-1000//” but there is no yaytmp-1000/ directory under /tmp
I previously installed r-testthat doing the mv command but there is still no directory called yaytmp-1000/ . I installed r-testthat using yay so what can I do?

thanks for your time :slight_smile:

Have you already built the package? After git cloning the repo, you should run makepkg -s from within that directory.

1 Like

yes , I’m new on this sorry haha, this worked! thanks

1 Like

Mm, @valentin_97 this is a duplicate post.

@dalto why not simply yay -S rstudio-desktop?

Easier to keep up to date?

Since he had already manually cloned the files, it seemed logical to run makepkg since that was the only step remaining. But sure, you could you use yay too.

Once it is installed, it doesn’t really matter how you installed it as long as you used the package manager to do it. Running yay later on will still update it in the future even if you build it with makepkg.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.