Can't install EOS; Main.py raised an exception

Hello everyone! Newbie here!

I’ve been trying the better part of this day to install EndeavourOS on my system but I keep hitting this exception during installation. I’ve tried different USB media tools that where recommended, but I am using Ventoy as my main tool. I’ve also tried changing fast boot, secure boot, legacy but the error keeps popping up. I also tried a lot of other tips like disabling the hwinfo package or creating a new partition with gparted.

I’ve been scrounging around forums for information but I just can’t seem to find someone else with the same Main.py exception (only BooSt.py). Here is the generated log: https://termbin.com/r2jq.

Can someone help me or point me in the right direction? What am I missing here?

Thanks in advance!

It looks like your EFI partition is being mounted read only.

The most common cause of this is not disabling “Fast Startup” in Windows. Without that disabled, Windows leaves the disks marked dirty and they get mounted read-only in Linux.

If you already disabled that, try repairing the filesystem.

I’ll check the Fast Startup setting. Am I correct in assuming that I have to use the fsck command to start repairing the filesystem, if it comes to that?

EDIT: Fast Startup is disabled, yet the error shows it’s ugly head. I’ll try repairing the filesystem

EDIT2: Welp, I am at a loss. Repairing the filesystem worked, it finally finished the installer, only to tell me that the installation had failed with the same main script error but without any codes or logs.

Maybe a Calamares bug.
The installer mounts (no errors) sda1 as installation /efi, while it is NTFS partition on an MBR/MS-DOS drive (sda) and instalation root (/) is at nvme0n1p5. After installation is completed, it tries to access/write to the /efi, but fails (error: read-only fs).

2024-05-16 - 18:34:57 [6]:     .. Running QList("mount", "-t", "ntfs", "-o", "fmask=0137,dmask=0027", "/dev/sda1", "/tmp/calamares-root-2mgvyxc1/efi")

sda1 is 900GB NTFS :face_with_head_bandage:


2024-05-16 - 18:39:43 [6]: [PYTHON JOB]: "Disk /dev/sda: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors\n" 
2024-05-16 - 18:39:43 [6]: [PYTHON JOB]: "Disk model: Samsung SSD 860 \n" 
2024-05-16 - 18:39:43 [6]: [PYTHON JOB]: "Units: sectors of 1 * 512 = 512 bytes\n" 
2024-05-16 - 18:39:43 [6]: [PYTHON JOB]: "Sector size (logical/physical): 512 bytes / 512 bytes\n" 
2024-05-16 - 18:39:43 [6]: [PYTHON JOB]: "I/O size (minimum/optimal): 512 bytes / 512 bytes\n" 
2024-05-16 - 18:39:43 [6]: [PYTHON JOB]: "Disklabel type: dos\n" 
2024-05-16 - 18:39:43 [6]: [PYTHON JOB]: "Disk identifier: 0x57e78ebf\n" 
2024-05-16 - 18:39:43 [6]: [PYTHON JOB]: "\n" 
2024-05-16 - 18:39:43 [6]: [PYTHON JOB]: "Device     Boot Start        End    Sectors   Size Id Type\n" 
2024-05-16 - 18:39:43 [6]: [PYTHON JOB]: "/dev/sda1  *     2048 1953521663 1953519616 931.5G  7 HPFS/NTFS/exFAT\n" 

@dalto what is with \n ? Could be eos?

\n is the end of line character. It is being printed due to the way the debug output is generated.

1 Like

Well, after many tries and lots of troubleshooting I just gave up on installing it with dual boot and wiped the entire drive. This worked.

So for anyone who comes here with the same error code this is a, but probably the, solution.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.