Can't get usb live work

Hello

I’ve decided to try out EndeavourOS , I’ve downloaded iso, I’ve put it on usb using Rufus, secure boot is disabled in bios.

Usb starts I see menu to choose which version I want to boot.

I have on board gpu i5-10600, so I’ve chosen version free, then it screen turn black and after 20 sec ot so screen goes to sleep…

I’ve tried to change boot parameters like changing modset to 0 on Radeon etc , Nvidia is blacklisted and then I can go past black screen but… after everything loads with green ok OK when x server should start I got error , please see photo.

Can anyone help? I really want to get it working

Thank you.


Likely an issue with the installer medium. Verify the checksum, try again, try with Ventoy or Etcher, and try a different USB pen drive.

1 Like

I agree with @jonathon it’s most likely because it was created with Rufus. My self i would use etcher. But on linux I’m using popsicle or you can use dd. I’m not a fan of Ventoy but some use it.

thanks , i will try , altought this guide says not to use etcher and use rufus

Create install media (USB key) – Discovery (endeavouros.com)

i hope this time it works

I personally have used etcher and not had any issues. But, that was mostly on Arch Linux. I then switched to posicle recently. Are you are creating a live usb from windows? Or another version of linux?

Edit: The reason they stopped recommending it is because of privacy issues related to them gathering user data?

nope, still no luck , exactly same problem :confused: - yes i did use windows. I don’t think it’s usb creator issue

Make sure secure boot and fast boot are off in UEFI. Also check if it has the keys removed.

I did that , all disabled by default, see attached, just to say I installed fedora recently without any issues, for some reason can’t install arch based distribution, tried manjaro before and there was exactly same problem


20210528_204825

Did you clear the secure boot keys before disabling it?
Edit: Okay i see it at the bottom.

no - it was disabled by default , all these secure options were disabled from new.

I do see one error message.

xf86EnableIOPorts: failed to set IOPL foe i/o (not permitted)

I don’t think this info is relevant as it is just a message telling what it can’t do for a specific reason. :thinking:

Will the Arch installer image boot correctly?

when ive tried to boot manjaro - it did same - had same error , it boots as it should - just after I press actual boot screen goes black

Are you able to boot on the live image and post the following link from this command.

inxi -Fxxxz --no-host | eos-sendlog

That didn’t answer my question. Does the Arch installer boot?

In otherwords @jonathon is asking does the live ISO boot up fully to the desktop to be able to run the installer? Or it isn’t even booting up all the way.

Actually, I was asking whether the Arch installer image would boot to its terminal/CLI interface. This provides a baseline to test whether 1) the kernel works 2) the image has been written correctly 3) the USB drive is working 4) something will actually boot correctly.

Oh …okay i misunderstood also. Sorry.

No, only menu

That’s not the Arch installer image.

OK, I’m out.

3 Likes