Can't find out where to change time tray language

My bottom right time at tray icon is in germany language. it shows “mi” as wednesday… and “okt” as october… i can’t seems to able to find where to adjust that. although my whole os is in english already.

I think I remember you were using kde/plasma.

If that is the case it is in System Settings->Regional Settings->Formats.

It is defined by your region however you can also override the date and time specifically.

everything seems to be fine in regional setting > format.
united state (en_us).
the time and date under “description” area all in english

see, everything is in english, but bottom right corner, the date is still in germany.


oh… i think i need to “tick” the “detailed settings” to change them to english. i guess.

BTW, since i see these detailed settings that i can fine tune, how to make my system display metric system under “measurement units” ? which should i choose ?

Indeed. It looks like they need to be changed.

1 Like

what is “default ©” option (in drop down menu) means ?
unfortunately i can’t see the effect, becuase i will have to logout and log in to see the result.