Can't connect to internet from terminal, no interfaces found except Loopback

Hello everyone! Bit new here so I apologize if this is the wrong forum but figured might as well post here since I’ve only been using Endeavour for a week or two and the solution might be obvious

Anyways, my PC has always had a bit of a problem finding WiFi networks on Endeavour. I did a bit of digging and realized that my PC wasn’t recognizing any WiFi interfaces at all. Thankfully my ethernet worked fine and after I installed linux-firmware my WiFi problems mostly went away

However today my KDE desktop kinda sorta broke and I got on with trying to fix it from the terminal after CTRL+ALT+F3 on the login screen (not the main topic of this post since I don’t want to combine multiple topics into a post)

However I quickly realized that I couldn’t actually carry out most of the solutions because I was not connected to the internet. I ran ip link show and it only showed loopback and no other interfaces. Sure enough even when I plugged in ethernet cable, still no internet

I rebooted multiple times and it was broken all except one times. The time the internet did work fine was when I booted up my EndeavourOS liveboot from a USB so I can access some files I needed for tomorrow. Surprisingly enough, when I took out the liveboot USB and booted back into my normal system so I could attempt to return to fixing it, the internet worked! I did a quick update and after trying a couple more things, rebooted. I then once more had no internet, and unfortunately this time, livebooting from the USB once and then returning to my normal boot didn’t magically fix it this time

I’m kind of at a loss, does anyone have any sort of suggestions? Thank you!

Hi there,

Is Networkmanager running/enabled?


$ systemctl status NetworkManager

and see if it is running.

Yes it seems to be running

I unfortunately can’t copy and paste the whole output but something I did find interesting are the following snippetd of output

ovsdb: Could not connect: No such file or directory
ovsdb: disconnected from ovsdb

No idea whether that’s relevant or not but hopefully it is!

I’ve attached a picture of the output as well in case anyone would like to read it but again, it’s a picture and not a screenshot so might not be the most legible


I was going to say

rfkill unblock all

But rereading your post the WiFi isn’t even listed from

rfkill list

try USB tethering from smartphone, if you need just internet to patch updates or install some packages

If you can boot on the live usb with internet and provide your hardware output would be helpful. Please provide the link from this command.

inxi -Faz --no-host | eos-sendlog

My output from rfkill list was:

0: hci0 Bluetooth

Soft blocked: no

Hard blocked: no

Never done this before but will definitely try it out later today, if I can find a USB C to USB cable ofc

Unfortunately wifi doesn’t seem to be working on the live boot anymore which is kinda weird

I checked the interfaces and it DID have Ethernet interface but its state was down and I couldn’t set it up for some reason

when I plugged that in the Ethernet didn’t work

Strange that your ethernet isn’t working either from the live boot.
without internet it’s hard to copy/paste logs eh? :stuck_out_tongue:
Do you see any error messages in dmesg that might be related to the network?
dmesg --level=emerg,alert,crit,err,warn
what do you see hardware wise?
lspci -k
is it loading the firmware?
dmesg | grep firmware
perhaps the module is providing some info?
dmesg | grep iwlwifi

On my most recent boot up WiFi is working again and I’m not sure why? Guessing it won’t work again next reboot tho so the relevant information is as follows

For dmesg I had a lot of output but it does explicitly say that it’s unable to find any system interfaces – despite the fact that wlan0 is (finally) working

Here’s a picture of the full output
Uploading: 16391920822555118593977661281182.jpg…

For lspci -k the relevant outputs are:

Ethernet Controller: Realtek Semiconductor Co Ltd RTL8111/8168/8411 PCI Express Ethernet Controller (rev 15)
Subsystem: ASUSTeK Computer Inc Device 208f
Kernel Modules: r8169

dmesg | grep iwlwifi had no output

Since my wifi suddenly and unexplainably started working again, I went ahead and ran it

Here’s the url it outputted

Doesn’t show anything!

Well that’s not good

Unfortunately after restart it does indeed seem to be broken wifi again

Doesn’t your ethernet work either?

Unfortunately yes, my ethernet doesn’t work either

You have RTL8111/8168/8411 using r8169 kernel module for ethernet. You have Intel WiFi using iwlwifi. Both should work no issue.

I don’t know what this is you have running here but most likely something to do with it. This is openswitch server. You must have some software on the system using this.

ovsdb: Could not connect: No such file or directory
ovsdb: disconnected from ovsdb

Hello everyone! Sorry for the late response, was a bit busy with finals

In the end I just ended up reinstalling my system. This fixed the ethernet driver but not really the wifi card

Apparently after doing some Googling though it seems like there might be an issue with my WiFi card specifically (MediaTek Wi-Fi 6 MT7921) as lots of people seem to be having problems with it both on Linux and Windows. Also I probably should’ve mentioned this earlier but I am indeed dual booting (already have secure and fast boot disabled though)

Make sure you have fast start up feature in Windows disabled. This is different than fast boot in the Bios.

This should be using mt76 module. As far as i know it should be in the kernel.

inxi -Na