Can't change email on some sites

In the last 2 days I’ve tried in 2 places to update my email on sites, and can’t. First, cubebrush, which is less important, but, just now, Iceland, which I need to update to start online-shopping there for groceries. I’ve just emailed them, but thought, while waiting (the return email says there could be delays in responding), to see if anyone else is finding this is happening.

Could this be to do with something referenced in a thread recently, a new web protocol, or is it google trying to push people away from anything firefox-based? I’m using Waterfox as the least worst I’ve been able to find; usually the classic version, but have tried both password changes in the current version too, and same results. Can’t think of anything I’ve done differently, or have installed differently, and it surely can’t be to do with the modem being new, lol, which is the only thing. Is it more action against VPN’s? Using ExpressVPN, and, a few weeks ago, experienced Amazon and Tesco refusing access to sites, and blocking my bank card payments on the days deliveries due, nearly causing deliveries to fail, except that I called Tesco quickly.

Yes, practically could install another browser, or turn off VPN, to test things, but if there’s any other answer before having to resort to trying that, I’d be very glad of any advice. Plus am not going to be turning off VPN ultimately anyway.

Has nothing to do with a new web protocol IMHO.

1 Like

Are there any facts anywhere that I can read about this new web protocol, to see if it could effect things in this way? I’ve just tried searching HTTP 3 and reset passwords, but can’t find anything even about HTTP 3.

Could it be action against VPNs, or something else?

Honestly that has nothing to do with it as your browser isn’t even using it. It’s not implemented yet.

1 Like

As of October 2020, the HTTP/3 protocol is an Internet-Draft and has multiple implementations. According to W3Techs 7.3% of the top 10 million websites support HTTP/3. Stable versions of and Chrome support HTTP/3 in its current form, but have it disabled by default. Safari 14 will ship with HTTP/3 enabled by default.

Yes, I saw that in the thread, but I can’t make sense of what’s happening about passwords. Something has changed, and I’m not sure if it’s to do with this, or anti-VPN action, or what.

It could be your VPN settings possibly. Is your email not working? Not sure what your issue is?

Nothing has changed on my end; just a new modem, which has been working fine for the last week. I just got a response email from Iceland so no email issues either. VPN’s working fine.

What is the issue then?

That I can’t change emails on sites. I enter the new email, but page doesn’t accept it; old email keeps showing. In Cubebrush’s case, a message came up saying they’d send a confirmation email to my old email address. With Iceland, again the page won’t accept it, and no confirmation email has arrived.

It has something to do with the site then. If it won’t accept the email address you are putting in then it’s not going to send you a confirmation. The other one not sure why you didn’t get one unless you missed a step?

Missed no steps. Just seems odd that I’m having the exact same issue on 2 very different sites.

Possibly a black listing of your email address domain. Try with a gmail?

Are you thinking because of the vpn?

Thanks for the suggestion @onyxnz plus that’s pretty scary either way … I’d need to fix that somehow, as I won’t use anything google. It’s I’m using, which I understand is very reputable. Even DeviantArt accepted it, lol, which had been a problem with previous tutanota address.

1 Like

Thanks for the link. :slight_smile: thankfully comes back as OK. Phew!
There’s a timeout CBL right at the bottom, but not sure that’s an issue, as I’m getting emails fine.

1 Like

Why would the email ip address get blacklisted?

The domains can often get black listed based upon the IP addresses they are sitting on. When a site on that server is abused/misused to serve spam particularly.
Many sites can share an IP address on shared hosting particularly.

Oh okay … i wasn’t thinking about that. Makes more sense. :slightly_smiling_face:

1 Like

It also happens with some ISPs who have things badly configured; if you use a standard for instance, then the mail filters filter based upon the domain because they have seen too much bad spam coming from that ISP. It’s painful, and less common now, but still happens.