Can't boot to DE (xfce) After installing proprietary nvidia drivers

It looks something like this picture I got from the internet:


I installed the drivers using nvidia-inst command and then when I restarted my laptop again it cant boot.

But when I disable optimus on the bios I can boot normally. What I want to achieve is to be able to boot with optimus on again. can someone help me?? (I already tried nvidia-inst --n but it doesn’t seem to work)

My system:
Dell Latitude E6430
Intel i7 - 3540M
NVIDIA NVS 5200M
Thanks in advance

This is a fermi card - which drivers did you install? You need:

So boot live media, chroot in and uninstall the drivers that are not the correct ones, then install the correct ones with yay, exit chroot, reboot.

While installing the drivers I entered these commands:

  sudo pacman -Rs --noconfirm --noprogressbar --nodeps lib32-nvidia-utils nvidia-utils

   yay -Syu nvidia-390xx-dkms nvidia-390xx-utils nvidia-390xx-settings

sudo nvidia-installer-kernel-para nvidia-drm.modeset=1 add

Can I just completely remove the drivers

Graphics:
  Device-1: NVIDIA GF108GLM [NVS 5200M] vendor: Dell driver: nvidia v: 390.157
    alternate: nouveau,nvidia_drm non-free: series: 390.xx+
    status: legacy (EOL~2022-11-22) last: release: 390.157 kernel: 6.0
    xorg: 1.21 arch: Fermi code: GF1xx process: 40/28nm built: 2010-2016 pcie:
    gen: 2 speed: 5 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:0dfc
    class-ID: 0300

This used to show drivers : N/A is there any way to get back to this state and just use my integrated GPU as it seems to run without any issues?

Thanks for Replying btw.

Yes, should be OK.


Booting to DE. I get stuck here what should I do?

Did you run reinstall kernels?

Nevermind It’s fixed thanks for helping me :grin:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.