Can't boot the installation USB (Manjaro)

Hey all!
I have dd’d the latest ISO to the USB I use for installing operating system. My laptop runs Manjaro XFCE at the moment. The USB’s not recognized by the boot menu.
I know

  • that the iso is not corrupted
  • that it’s possible to boot from it (tested with qemu -usb and it worked)
  • that the laptop can boot from an usb (did it when installing manjaro)
    What have I tried so far:
  • changing to UEFI/BIOS and vice versa
  • changing boot order

What can I do? Can anyone help me?

Hello @vankoodaniel
I personally don’t use the dd command on linux. I use etcher and have never had an issue ever. You should be using UEFI to boot if your system is UEFI. Is secure boot and fast boot turned off in UEFI settings? If you are saying it doesn’t see your USB device then you have to look at the UEFI settings and select the proper boot device and or partition as the entries can be misleading. You may have improperly selected an entry that is not the correct one.

could be that laptop is equipped with such new nvidia graphics?
you could try this ISO (nvidia enabled)

As @joekamprad has provided a link to an Nvidia enabled ISO if you have Nvidia Graphics. I wasn’t understanding if you have a problem with the USB being recognized as that is what you have stated or whether it is trying to load and failing to boot on it because you have this hardware.

You could provide us the output of this command. You may have to install inxi and you can do this on your current Manjaro installation.

Inxi -FGz

1 Like

Hey all,
I managed to boot it, the pendrive was the fault (I think). This time I booted from a 3TB external HDD.
Thanks for al your support :), My laptop has no NVIDIA graphics by the way.

1 Like