Can't boot OS after updating

Hi. My install has been running great for a couple of months now, but then after installing some updates last night, my machine won’t boot anymore - it just hangs at “Loading Initial Ramdisk”.

I tried booting using the fallback kernel but it does the same thing. Can’t change to a different TTY, and removing quiet from my boot command doesn’t make any difference either.

I’ve tried chrooting in from a live-usb and reinstalling the kernel, but that didn’t make any difference, nor did installing the lts kernel and booting that.

I’m not sure what else to try now - I don’t even know what update killed it. I usually run updates once every day or 2, so it must be something recent I think.

I backed everything up, formatted the disc and reinstalled. Everything boots up fine, and then as soon as I run an update and reboot, it’s dead again.

What can I try next?

In order for others to assist you, it would help to know as much information as you can give. Like what is your DE (Gnome, Xfce, KDE, etc), are you using nvidia/nouveau drivers, are you using ext4/btrfs, what hardware are you using (pc or laptop model number for example, this does not reveal any personal info btw it just allows us to look up your hardware specs), you already mentioned both kernels don’t work so that’s a start that might help indicate where your problem lies.

1 Like

If you need to know what updates happened, they are listed in the file /var/log/pacman.log. That might also enhance your understanding of the problem…

The hardware info most often helpful is inxi -Fza - pasted into a message with triple ` both before and after the text.


OK great. I was using Gnome with Nvidia drivers (nvidia-dkms), and btrfs. The machine is a desktop with an i5-10600, 16Gb memory, and a geforce 1070. install is on a sata drive - sdb2, and the efi partition is on the nvme (along with windows 10).

I already wiped it and reinstalled from the current latest endeavour ISO, booted into the OS, and then did nothing to the install except run an update, and then rebooted and it was dead, so whatever it is, it was new between whats on the current ISO and now.

Since I wiped it, I don’t have the log still though. I have done another reinstall (using the offline install) so i can use the system still, and am just not installing updates so I can keep going, but if i need a log, i can do that and get them, and then i guess reinstall again after?

Output of inxi is here:

Run checkupdates to see what would be updated if you did update. Post what it outputs here, please.

BTW, you don’t need to reinstall the OS every time there is a problem. Usually, there are more elegant solutions than that.


Yeah, I’m aware that I should be able to fix it, i just don’t quite have the know-how yet, and I wanted to get back to my rimworld game! I definitely want to figure this out though - i’m sick of windows.

So I did a checkupdates, and there’s quite a lot there, but I got it in my head that it was the kernel update that was killing me, so I ran the update but ignored the linux and linux-header packages.

Turns out that was the wrong call! Still the same problem as before, so looks like i’ve killed it again. I’m booted onto the live USB now, and grabbed the pacman log here:

this is the pacman log from the offline install.

I would suggest to install the LTS kernel and headers in addition to the main kernel.
sudo pacman -S linux-lts linux-lts-headers after installing it will be the default booted kernel.
And keep in mind that in general not booting into graphical environment does almost never mean that your system is “dead” only a little part somewhere is failing.


Ok thanks. So I can boot via the lts kernel now, so that’s great, however I now have not network for some reason.

The only interface ifconfig shows me is lo, but lspci still lists the Ethernet adapter there (realtek rtl8125).

I guess it’s just not loading a driver or something? I’m not sure what to check for now.

you need driver that is builded against lts kernel, or dkms one to have it building modules for all kernels:


If you do not had a special driver package installed before you may used the r8168 package there would be also the lts version of it: r8168-lts

But show/check what you have installed:

pacman -Qs r81


Ok, that command doesn’t return anything, and there doesn’t seem to be anything called r8125 anything to install.

I tried installing r8168 and r8168-lts, but it still boots in with no network interfaces.

and this device was working before on default kernel?
you could give bootlog to see if we got a hint:
journalctl -b -0 | eos-sendlog

it had been working for several months before, yeah, and it also works fine on the live USB and from a fresh install.

i ran that command from the chrooted live usb and got this:

any clues in there?

Sep 11 21:44:40 EndeavourOS kernel: RTL8226B_RTL8221B 2.5Gbps PHY r8169-0-700:00: attached PHY driver (mii_bus:phy_addr=r8169-0-700:00, irq=MAC)

Sep 11 21:44:40 EndeavourOS kernel: r8169 0000:07:00.0 enp7s0: Link is Down

Sep 11 21:44:42 EndeavourOS kernel: r8169 0000:07:00.0 enp7s0: Link is Up - 1Gbps/Full - flow control rx/tx

So your network is using the r8169 driver included inside kernel…
On the Live ISO you could give me:
inxi -N | eos-sendlog ? to see if it is really using that driver and does not switch to r8168 …

And live-ISO has older kernel then current …

1 Like

ok - this is that from the LIVE usb:

and yeah, live usb is running kernel 5.13.12-arch1-1

OK, a little progress.

Didn’t realise that you were saying the 8125 driver was on the AUR sorry - i’ve installed that and now I can boot into the GUI on the LTS kernel and I have internet access - yay!

However - still can’t get very far using the standard kernel (and tried Zen and got the same result).

I’m also a bit mystified as to what I did wrong, or what happened. My system has been working fine for ages, and then with 1 batch of updates i lose the ability to boot using the standard kernel and also lose my network access which had previously not required a driver?

Sorry for all the questions - just trying to learn as much as I can. Thanks all for your help so far.

So where should i be looking next? i.e. how can i get back to using the standard kernel?

Further update - I used the ‘downgrade’ tool to go back kernel versions, and found that all the 5.14 kernels have the same non-booting issue for me.
As soon as I switched to 5.13.13, everything came right again, so it seems like perhaps some part of my hardware has a conflict with something in 5.14.
That being the case, what should I do next? i.e. what would be my troubleshooting steps to figure out enough about what’s going wrong to be able to file a bug report or something?

arch just pulls out the first 5.14 kernel … there will come updates soon we are already on 5.14.2 but it is normal to got some hickups on kernel version changing… therefore LTS kernel comes in to get around… or users on AUR providing fixed drivers like the one for your device…

the one :
using dkms and will build modules against all installed kernels so should work also for the main kernel…


ok cool - so i’ll just sit tight with the LTS kernel for a bit then and try the vanilla one again later.

Thanks so much for all your help!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.