Can't boot into Endeavour after reinstalling Windows

Hey all,
I’ve ran a dual-booted Windows+Endeavour combo for quite some time now, and only recently decided to reinstall Windows due to it just running fairly slow. Since then, I can’t seem to be able to boot into Endeavour, no matter what I do. Here’s some general info:

→ the GRUB entry in my BIOS’ boot menu disappeared (i know it’s a usual occurence, since Windows tends to shove its bootloader wherever it can (it’s not my first Windows reinstall while dual-booting), but last time it happened (~1 year ago), I was able to fix everything by booting into a live environment, mounting the Linux partition and reinstalling GRUB (or so I think, it’s been a while - bad memory, lmao). It didn’t work this time.

→ upon trying to boot straight into Endeavour via the Windows’ Advanced Boot Options, I’m greeted with an error - Bootloader Not Found,
→ upon trying to boot from EFI file, I can’t find anything GRUB-related on the EFI partition (overwritten by Windows, I assume),
→ after booting into Endeavour via Super Grub2 Disk, it boots into emergency mode, with errors (check attached screenshot),
→ i’ve tried disabling the Windows Boot Manager via efibootmgr, with no effects,
→ i’ve also changed the boot sequence via efibootmgr - once again, nothing happened,
→ and i’ve tried to reinstall GRUB from the live environment a couple times now, to no avail.

Running fsck a couple times reported no errors. Here’s my fdisk -l output:

Disk /dev/nvme0n1: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: INTEL SSDPEKNW512G8H
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 232CA62A-9E92-9D44-8393-AA460C988F0E

Device Start End Sectors Size Type
/dev/nvme0n1p1 2048 34815 32768 16M Microsoft reserved
/dev/nvme0n1p2 34816 616447 581632 284M Microsoft basic data
/dev/nvme0n1p3 618496 512323583 511705088 244G Linux filesystem
/dev/nvme0n1p4 512323584 512528383 204800 100M EFI System
/dev/nvme0n1p5 512528384 999120886 486592503 232G Microsoft basic data
/dev/nvme0n1p6 999120896 1000212479 1091584 533M Windows recovery environment`

and the efibootmgr:

[liveuser@eos-2023.08.05 ~]$ efibootmgr
BootCurrent: 000A
Timeout: 0 seconds
BootOrder: 0000,0001,0006,000A,0009
Boot0000* endeavouros HD(1,GPT,9bd35da6-8005-914d-9893-026f63c37919,0x1000,0x96000)/File(\EFI\endeavouros\grubx64.efi)
Boot0001* Windows Boot Manager HD(4,GPT,cc5330ee-b49b-4fb5-9c5d-5dfcc56d515d,0x1e897000,0x32000)/File(\EFI\grub_uefi\grubx64.efi)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000000000100000010000000040000007fff0400
Boot0003 grub_uefi HD(1,GPT,4c6cc4a9-05c4-470a-ac50-e0742997f999,0x800,0x82000)/File(\EFI\grub_uefi\grubx64.efi)
Boot0006* Internal Hard Disk PciRoot(0x0)/Pci(0x1,0x2)/Pci(0x0,0x0)/NVMe(0x1,00-00-00-00-00-00-00-00)/HD(4,GPT,cc5330ee-b49b-4fb5-9c5d-5dfcc56d515d,0x1e897000,0x32000)0000424f
Boot0009* USB Drive (UEFI) - Hard Drive BBS(HD,0x0)0
Boot000A* USB Drive (UEFI) - USB PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x3)/USB(2,0)/HD(2,MBR,0xc2aa14f4,0x728c000,0x10000)0000424f

(i spared the ID of the USB drive - it’d take up too much space in the post)

Every time I change the boot sequence with efibootmgr -o to the correct one, it boots straight into Windows, and then reverts to the one displayed above.

What am I missing here? Any help would be appreciated. I’ve been stuck on the matter for over 2 days, and it’s getting tiring…

I think this is the right course of action. Can you describe the steps you are doing in the thread? Maybe you are just missing a small step or something.

Try logging in to the forum from the live environment and copy/paste the commands into the thread as you go so we can see what is happening.

Try what @BluishHumility has posted above because installing Windows after will cause grub to no longer work.