Can't add space to my partition

Hi guys,

I want to increase the partition size on my EOS Plasma. GParted will not allow me to add or subtract storage. I do have another used partition just to the right of my Plasma partition, however I have lots of unallocated memory just to the left.

Is there a way to do so if I perhaps log into another partition’s OS, while Plasma is unmounted? Or maybe through the terminal?


You cant expand to the left.

You have to move the partition to the left and then expand it.

Yes, you cant do any of those things unless the partition is unmounted.

If your filesystem is btrfs, there are easier options.

1 Like

Thanks Dalto.

GParted does not allow me to move any of the partitions, only to resize them.

All my Linux partitions are on EXT4.

Edit: Is it safe to copy the partition that’s in the way, in this case EOS Cinnamon, into another sector on my drive, then delete that partition, in order to get to the unalloacted space? Will I have any issues operating the copied Cinnamon after the move? Maybe if something is set to load on a specific partition number in the original Cinnamon partition?

If you have a good backup and time to restore it, everything is safe. Otherwise, definitely not safe.


Note that the easiest alternative way to “expand” your disk is to simply mount the extra (left) partition onto your existing EOS Plasma. Then you can use the new mount point to something that needs more space.
So if you don’t feel adventurous, this is the approach I’d recommend.

But if you want to copy the Cinnamon partition, at least these things are needed:

  1. Make good reliable backups to an external drive of everything valuable to you (typically personal data) from all partitions of the disk. This is the most important step.
  2. Find out which of your installations is in charge of booting. If it is the Cinnamon thingy you are going to copy, think twice, since it will take more steps than presented here. For example, you must make it bootable again, and you must know if MBR or UEFI is used.
  3. Copy the Cinnamon files e.g. with cp -a of rsync to the formatted target partition. Note that copying must preserve also permissions of the files, otherwise it likely will not work.
  4. Adjust some files in the new Cinnamon partition, like UUIDs in /etc/fstab, and UUIDs in /boot/grub/grub.cfg (if using grub). If you use systemd-boot instead of grub, see this.
  5. Make your system’s boot manager (in partition that is in charge) recognize the new Cinnamon “installation”, e.g. sudo grub-mkconfig -o /boot/grub/grub.cfg for grub.

Please note that the list may be missing something essential, so no guarantees.

For this reason, I always make a single partition per physical drive (with the exception of EFI partition, of course). It’s really the easiest way to manage storage.

1 Like


I really like the idea of mounting the unallocated partition into Plasma. But what you’re saying is to simply format the extra space and use it as storage? Or actually blending in the partition into the Plasma partition?

GParted only gives me an option to make a new partition. Which if that’s what you’re saying, I could live with that… Does having the Plasma partition near-fully occupied cause performance issues though? I’ve seen it start to lag on me.

Just create an new ext4 partition in the unallocated space with GParted and then mount it (add it to your fstab). Personally, I would create a directory somewhere in my home directory and use that as a mountpoint.

Next time you install your OS, I recommend having the whole drive be a single partition, so you won’t have this type of problem in the future.

I actually came to this realisation back when was using Manjaro. Some stranger online suggested to have a home directory on a separate partition, and to me, at that time, that seemed like a good idea – makes it easy to reinstall the OS without touching your home drive. That’s great, right? Wrong.

Well, it turned out to be very difficult to judge how much space I’m going to need on my root partition, and how much space is going to be needed by my home partition. The effect was that one was always close to full, while the other always had a lot of free space. So I would store stuff on the other partition and symlink it back and forth, completely defeating the purpose of having multiple partitions. I concluded that this was a bad idea. Why partition my drives at all? It’s not like we are using MBR partitions where the size limit is an issue. And it turned out I very rarely install the OS, and since I have a good backup, I just restore that. One partition per drive (+EFI). No swap partition even, I use a swap file.

1 Like

Thanks for the help Kresimir. How am I able to access read/write on the new EXT4 partition, by using fstab? I can only read at the moment.

Just add a line to your fstab, something like:

UUID=<uuid> <mountpoint> ext4 defaults,noatime 0 2

Where <uuid> is the UUID of your new partition (something like 6bb8caf0-db93-40ed-9773-19cd6fd8d04a) and <mountpoint> is the path to the directory you want to mount to, e.g. /home/username/storage (make sure the directory exists).

To find out the UUID of your new partition, you can just run:

lsblk -f

I think you can also see it in GParted somehow.

You may also want to read up on the options: (defaults,noatime 0 2 should cover a majority of use cases, but you may want to research that a bit).

Then just run:

sudo mount -a

That should be all you need to do.

You can run lsblk -f again to check that everything is mounted properly.

1 Like

Thank you!

1 Like

Yes, it can cause such issues. But I suggest (unless you already know) you find out what causes the existing partition to be nearly full.

It could be just the package cache, which is rather easy to manage e.g. with
paccache-service-manager or just paccache.

1 Like

Thank you. For some reason my cash manager doesnt start automatically, but it did clear up some space.

I’m trying to delete a file but since my partition is full it wont fit in the trash. I tried going in the konsole with the following command:

sudo su
sudo rm -R /home/admin/pCloudDrive/DJI_0015.MP4

also tried

sudo rm /home/admin/pCloudDrive/DJI_0015.MP4

both times it says permission denied, even though i’m in sudo. I want to force delete this file

Tip: if you run terminal commands, please show the the full output along with the full command. Otherwise some important troubleshooting clues may be missing.

What does command

ls -l /home/admin/pCloudDrive/DJI_0015.MP4


Note that you don’t need sudo su if you use sudo after it.
And you need sudo only if the file you are deleting needs permissions your account does not have.

manuel, it had said ‘no such file or directory’ but I was able to get it deleted with rm -V command. not sure what had caused it but i tried it with your sudo suggestion and it worked either way. Thanks!