Cant activate vfio "Kernel driver in use: nvidia" vga passtrough problem ( how to activate vga passtrough virtualization with nvidia nonfree driver )

Hi everybody.

i’m used this GPU passthrough guide for Manjaro and Windows 11 guests - YouTube and this Easiest GPU passthrough guide for Manjaro - YouTube tutorial for vga passtrough virtualization.

i have two gpu. one for mining one for using. i’m using nvidia gt1030. its not compatible with my monitor or gpu with nouveau driver. i cant use nouveau.

after used tutorail i can see this: ( some of lspci -nnv outputs )

2d:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Navi 23 [Radeon RX 6600/6600 XT/6600M] [1002:73ff] (rev c1) (prog-if 00 [VGA controller])
Kernel driver in use: vfio-pci

but i’m not planning amd gpu for virtualisation.

8:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP108 [GeForce GT 1030] [10de:1d01] (rev a1) (prog-if 00 [VGA controller])
Kernel driver in use: nvidia

i cant activate vfio-pci for nvidia gt1030 ( nvidia nonfree driver )…

Hi

I have just had a problem with Nvidia this was passed on to me try looking here
it may help you it may not.

My problem Here

HIH


Data

i’m tried “nvidia-inst” installer for nouveau. i’m not think using nouveau with kernel driver vfio. i need nonfree driver with vga passtrough virtualization. result monitor showing no signal. but this is something because its starting xorg. ( may be will solution for someone )

i tried mx linux and manjaro usb boots. nouveau result: black screen and disconnect message from monitor. i was used nouveau before. but my monitor changed. i’m thinking hp x32 monitor + display port + gt 1030 combination or one of them incompatible to nouveau driver.