Canon ir-ADV C7260 printer not printing via network

I began to use a newly installed EndeavourOS on my teachers laptop at school (starting this school laptop via USB SSD). All works, only printing is not possible.

My laptop is in a network ( where is also our printer ( I have installed all necessary packages conforming to , but the “Print settings” module cannot find this printer, only other network printers (also other Canons) in our local net. Same with CUPS (localhost:631). Btw, with my old USB drive (MX Linux 19), the printer has been found and worked on the same laptop.
I also tried to add the printer via it’s URI (with ipp or with lpd), providing also the PPD downloaded, but it did not work either.
(Btw, I read the similar topic on a IR-ADV 4225 printer, but it did not help me, as the problem there is related to secure printing, which, in our case is not active.)

Where can I look further? Which config files or other info should I post here?

There’s a great article on the (searchable) EOS-Discovery site:

Sounds like a firewall problem to me.

If "Newly installed ", the EnOS laptop has firewalld enabled during installation.
You may have to open a port for the printer. if I remember correctly, I had to open port 1900 UDP but I would check on that.

To temporarily test if firewalld is the problem,
sudo systemctl stop firewalld.service

But after testing, I would reboot the laptop to activate the firewall again.



Thanks for your help. Sound very interesting and I will try it next week. For the moment, I am so charged by everyday works that I can it do only then.
But I will write here about the results.

Temporarily stopping the firewalld unfortunately did not help directly with the already “installed” printers (that did not work). But I had success for the time being (at least with a disabled firewall):
I have tried again to find the network printer (with Print settings - New printer). I opened the list for Network printers, then did not see yet this particular Canon printer/copier in our building. But down at the list of found printers, I discovered another “Find network printer” and clicked on it. At the right side, I had an input field for the URL and entered the URL of this printer (without any protocol, just the URL) and clicked on “Find”. It looked for it and I got down of the already found list a lot (about 50 or more!) of mentions with this URL. The first one with a printer queue named “PASSTHRU”, the second one with a queue named just “ps” and others with “lp”, “LPTx”, “COMx” or just “prx” (x always stands for a number). I tried the “ps” queue and BINGO! The test page printed! I deleted in Print settings all the other “printers” that did not work and let only the one which worked.
Now, I have to reboot and look if it also works with firewall enabled.
Maybe this kind of searching for the printer would also have worked last week with firewall? I will see it soon and will report here.

After rebooting, with firewall enabled, printing still works and the printer could be found with the method described above.
So, it seems that was not a firewall problem, but a question of finding a printer that is not automatically found.

Thanks a lot for your help, nevertheless. It gave me at least the hope that I can find the clue and so I tried and looked again.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.