Cannot update with YAY, following error: yay: /usr/lib/ version `GLIBC_2.34' not found (required by yay)


I hadn’t updated my system in a while, and my Slack Desktop program stopped working. I updated the system using:

sudo pacman -Syu

and had no problems. However, when I try to update using yay I get the following error:

yay: /usr/lib/ version `GLIBC_2.34’ not found (required by yay)

Any help much appreciated

Welcome to the forum! :smile:

What’s the version of your glibc package? Command: pacman -Q glibc

I guess using yay with option --rebuild or --rebildtree could help.

running pacman -Q glibc returns glibc 2.33-5

I tried yay --rebuild and got the same error:

yay: /usr/lib/ version `GLIBC_2.34’ not found (required by yay)

The glibc package is outdated, you need to do a full system update with

sudo pacman -Syyu

But maybe your mirrorlists are not OK, so if the command above updates nothing, you should rank your mirrorlist first, and then update the system.

Ranking can be done with one of these programs:
rate-mirrors, reflector, or reflector-simple.

For example;

rate-mirrors arch --max-delay 7200 | sudo tee /etc/pacman.d/mirrorlist

The numeric value above is in seconds. A smaller value provides mirrors that are more recently updated.

Yes, you are right I think my mirrorlist is wrong. I first tried full system update but that said “nothing to updated”.

I tried rate-mirrors arch --max-delay 7200, however, got the following error:

bash: rate-mirrors: command not found

I do have reflector installed, how can I do the same command but using reflector instead?

Thanks for you help, I am a real newbie!

I suggest you try reflector-simple, it is a wrapper for reflector.
Simply select one or more nearby countries and click OK.

Edit: note that many mirrors from Germany and United States are rather good worldwide.

Sorry, that isn’t working. I run into the same error:

(base) reflector-simple
reflector-simple: info: reading file /etc/reflector-simple-tool.conf
reflector-simple: info: reading file /etc/reflector-simple.conf
/usr/bin/yad: /usr/lib/ version `GLIBC_2.34’ not found (required by /usr/bin/yad)

I tried opening the desktop program too and that wouldn’t open.

Then you can manually edit file /etc/pacman.d/mirrorlist.
Move some other mirror line or lines as first.
Then try updating again.

By the way, in what country are you using the machine now?

EDIT: you can also use this page: to create a mirrorlist, and copy the list to file /etc/pacman.d/mirrorlist.

1 Like

I updated my mirrors using that list and It is working so far, thank you!

I am now doing the full update and it is currently “downloading required keys” - what are these and can I trust them? For example:

Import PGP key 632C3CC0D1C9CAF6, "Balló György <>"? [Y/n]

EDIT: or:

Import PGP key C32217F6F13FF192, “Alexander Rødseth”? [Y/n]

1 Like

Do this first:

sudo pacman -Sy archlinux-keyring


sudo pacman -Syu


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.