Cannot set default output in Pipewire (Xfce)

I did not have this issue last time I ran Arch / Endeavour (Xfce 4.16) nor when I was running Fedora 34 (Gnome 40).

But this time, after installing Pipewire, I cannot set default output. It doesn’t remember my settings after reboot and defaults to the sound card instead of the headphones (not bluetooth, so it’s not a connectivity issue).

pavucontrol then set the default (“fallback”) output device?

Already done.
It ignores that setting completely.

Not at a PC but did you install pipeline-pulse?

Installed components are:

  • pipewire
  • pipewire-pulse
  • gst-plugin-pipewire
  • pipewire-media-session
  • pavucontrol
1 Like

Try pipewire-alsa

is media session as --user enabled ?

Stupid question: How do I check?

systemctl --user status pipewire-media-session
1 Like
 >> systemctl --user status pipewire-media-session
● pipewire-media-session.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/pipewire-media-session.service; enabled; vendor preset: enabled)
     Active: active (running) since Mon 2021-05-31 11:24:55 CEST; 3min 3s ago
   Main PID: 1056 (pipewire-media-)
      Tasks: 2 (limit: 19034)
     Memory: 8.5M
        CPU: 89ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire-media-session.service
             └─1056 /usr/bin/pipewire-media-session

maj 31 11:24:55 dorktower-xfce systemd[937]: Started Multimedia Service Session Manager.
maj 31 11:24:55 dorktower-xfce pipewire-media-session[1056]: GetManagedObjects() failed: org.freedesktop.systemd1.NoSuchUnit

This MIGHT have been fixed with today’s update of Pipewire…

1 Like

Yes, but also:

11:08:44 <wtay> I would want to do a new release soon, 0.3.29 was messy

Edit: 0.3.30 is in the repos.