Cannot login to Gnome

@FLVAL I hope I’m not going to have these issues on my Ryzen 3800X with an Radeon RX 590? Guess i better read up on this before i get this rig set up. :thinking:

Hi @ricklinux, don’t worry it seems to be more about GPU Ryzen, with the new kernel 5.4 and your 3800X, you will make it rocks…

Maybe read this about temperature patch for series 3000 with Linux 5.4

https://www.phoronix.com/scan.php?page=news_item&px=Linux-5.4-Hwmon-Zen-2-Thermal

1 Like

If iommu=pt (DMAR - DMA Read Request - is disabled in the kernel, but KVM still supports IOMMU and interrupt remapping) circumvents the problem, it is not tragic.

Has already (ger) existed with other hardware, other Linux distributions and other kernels.

The model of the laptop is Acer Aspire A315-41-R84R and the bios version 1.01. Kernel is the latest 5.4.1-arch1-1.

:smiley:

UEFI 1.15, 2019-08-12
…a Windows executable.

Folow the @axt and check your Bios, the latest one is done on 2019/08/12 Version : 1.15, could be good to give a try !

https://www.acer.com/ac/en/US/content/support-product/7540?b=1

They did some update about AMD SMU 30.80 on the 2019/03/14 Version : 1.13, check it.

Right, but it’s not a BIOS, even if mainboard/notebook manufacturers write it like this because of the inertia of the users, but a UEFI.

Of course one should have flashed the last available one. That is a basis.

But flashing isn’t harmless, you have to do it by the rules. Otherwise you brick the mainboard. Therefore many users shy away from it. But it’s important.

In his case the Windows executable comes in addition. He could extract it (but there are 2 UEFI binaries á 9.5 MiB, you’d have to check it out first). If a flasher is integrated in the UEFI (e.g. EZflash2…), he could flash. But like I said, you have to know exactly what you’re doing.

aleks has get further hints like WaylandEnable=false in “/etc/gdm/custom.conf” and iommu=pt as a boot option. This is now done really quickly and riskless.

1 Like

Tried to add boot parameters and to disable Wayland in /etc/gdm/custom.conf - result is the same.(do I need to change lightdm to gdm for this to take effect ?)
I’m trying not to consider uefi update as a must, since these issues don’t exist on some other distros I mentioned, yet on the same bios/uefi.

I repeat: The UEFI is a basis. The last available is essential. If a certain issue doesn’t occur with other distributions, it’s possible, that it will be bypassed there.

At least there is nothing about flashing in the manual. Of course that doesn’t mean anything.

With Acer you can sometimes flash “blind”, i.e. without display. Which has already been necessary… (I remember a certain netbook model). USB stick in a certain port, FAT32, BIOS/UEFI binary copied to it, booting with certain key combination…

Acer is a bit reserved about fwupd, only two other models are supported.

There are other ways. If it’s not possible with the previously mentioned, the easiest way for the inexperienced is to drag a Redmond system, pff, w/o Internet connection, w/o any updates, w/o missing drivers, w/o (!) malware scanner onto it. Only for flashing.

Update the Bios in the last years works better than before, it’s easier. Sure It always exists a risk when the electricity cut but it’s the same than to take a lightning bolt on the head !
I was updating Bios directly on the chips with electronic and works great but now with UEFI, not necessary…

That’s what I mean. :smiley: Customers came to the store where I worked back then (2009). They thought the netbook with the black screen was going to take a long time to repair.

But I had prepared a stick, because we had sold several units (mistake of the first version of this BIOS). Ten minutes later the customers left the store happy and disbelieving. :wink:

But: Just an anecdote. Not for your notebook!

1 Like

That’s right. If there not .exe only.

I (PC technician) have already flashed countless things. The coolest thing is hot flashing (2 identical mainboards, 2 socketed EEPROMs, only 1 EEPROM has a working BIOS, changing the EEPROMs during flashing…). :smiley:

Therefore, when flashing mainboards in notebooks, you often ask whether a charged battery is plugged in and the power supply is connected.

In other words, if the battery is dead, you can’t flash it anymore. :sunglasses:

In this case here, this is what the README.txt says :

How to update the BIOS:
Click DH5JV115.exe under Windows mode

Release Note:

  1. Update PI code v1.1.0.8.

Therefore I wrote:

If possible, you can change the HDD briefly to avoid having to delete the Linux installation.

I think @aleks has all the elements now to update the latest Bios in security.

I always update whether it is Bios or UEFI firmware. My latest Asus UEFI board has had 13 updates since it came out including the original. It probably won’t get any more and if it does it won’t be many as it’s going on two years old now. I have always updated every motherboard I have ever owned. Never ever had one issue with doing it. This is my first UEFI board and it has direct update over network or you can use a jump drive. No need to do it in Windows or using other methods.

Just did an update to UEFI 1.15.
It changed some of the settings (secure boot), and also wiped out grub, so I had to reinstall it.
So far, everything seems the same - problem with Gnome still exists.

Hello @aleks I have been reading your posts and i assume you installed Xfce and then you installed Gnome. So you have both desktops installed and you are able to boot into Xfce but not Gnome? Exactly what happens when you select Gnome and try to log in? I was wondering what process you used to install the Gnome desktop?

I did the standard EOS install, so first XFCE, then Gnome via pacman. Tried with both lightdm and gdm.
When I select menu entry (Gnome, Gnome on Xorg, Cinnamon, Budgie) and try to login, only blank screen with login wallpaper shows and mouse pointer goes down right on the screen. I can change to other tty.

A way to reboot your Gnome login screen that will use systemd. If you access to tty could you try (gdm) :

sudo systemctl restart gdm.service