Cannot login to Gnome

My hardware(laptop) has the following specs: Ryzen 2500u, Vega 8 APU, 8GB RAM.
I installed EOS from october image, because previous one was giving me strange artifacts (issue already known for amd gpu-s with previous kernel).
XFCE is working fine.
I updated pacman and installed Gnome. When I try to login, mouse pointer goes to down right of the screen, and nothing happens. It is the same if I select either wayland or xorg entry from the lightdm dropdown menu. Gnome doesn’t load up. Changing to gdm also didn’t help. I assume it is some issue with the graphics driver, currently it is amdgpu driver (kernel is updated to 5.4).
I was previously using Antergos for couple of years, and Gnome was working fine on the same hardware. (I also tried Manjaro Gnome and it is working normally)
Also, I installed steam and when I try to start it (runtime or native), the session logs me out to login screen.
I’m open to suggestions to what to do, because I currently have no ideas (I thought that this gpu was already included in previous kernel releases).
I really like EOS and the community, and would really like to make it work.

Hi,

First of all, welcome to the community and thank you for giving us a try.

I can recommend two things for you, the first wait untill our December release is available or (and that’s the fastest one) download the August release and affter install remove kalu and yay (sudo pacman -Rns kalu yay) update the system and then install Gnome and GDM.

With some hardware there’s a problem with the September release and up, we are working on it to solve this.

You can download the August release over here

Hi @aleks and welcome to EnOS

It comes certainly from the Ryzen GPU.
You have an excellent post on Manjaro for Ryzen fixed, begin with that, you have 3 possibilities :

  • In UEFI (BIOS) set Power Supply Idle Control (or something similar) to Typical Current Idle (or something similar) .
  • Add the kernel boot parameter: idle=nomwait.
  • Disable C6 states (both core and package) with Zenstates.py

Everything is in details there. I used a 2200G and got some others bugs too. Most important is to get the latest kernel and you have it on EnOS.

First of all, thank you for the warm welcome.
I decided to go EOS way since the downfall of Antergos, to be honest I’m really not considering any other distro when it comes to arch derivatives - tried Manjaro and Arco, but something is missing. EOS is something closest to Arch and I really like it, I think it goes in the right way. Been (and still am on my older desktop conf) a regular user of Mandrake/Mandiva/Mageia and Ubuntu/Mint, but with rolling distro you get a completely new experience - I think you will agree.
I tried install from the first beta, I think in July, and then the August release. I couldn’t get calamares to work - there was some graphical issue with amd gpu’s (xfce compositing problem or something) that got solved in October release. Like you said, I removed kalu (not yay tho), updated the system and installed both Gnome and gdm. But Gnome still didn’t start (same goes with Cinnamon and Budgie, but that is understandable, since it all relies on Gnome).
Right now, my system is updated each day, hoping that some update will fix the issue (maybe a clean install of december release would solve it?)
Anyways, thanks for the quick reply, I’m open to suggestions.

Thank you for the suggestions, I will surely try this.
Actually, when I got this laptop somewhere mid 2018, Antergos was one of the few distros that would even install on it. I’ve had some soft lockups and issues similar to other ryzen users (that use apu gpus), but it all got solved along the way, with some kernel updates. Graphically system was working well, I was able to play games on Steam and seemed that kernel amdgpu driver is ok. Now I’m not sure what exactly is causing the problem (like I said, Manjaro Gnome and steam on it is working fine).

I have similar problem yesterday after LTS update. After boot it shows only a blank screen and mouse cursor. I think i do a reinstall. Di you suggest the August release?

No, I think that is another issue, it was working properly so I think it’s wise to create a new thread with your specs mentioned.

1 Like

Because i have work to do, after the problem i install another distro. But i want to install Endeavouros again. The August iso is better?

You can try, but I think you run into the same problem again after updating the system. If you do, then give us your specs and what you have installed in a new thread.

1 Like

After LTS update, try the boot option :

iommu=soft

What is this?

AndreasDimo, what is what?

Parameter like iommu=soft or iommu=pt are known and readable.

You have been asked 2 times to start your own thread for your issue.

That’s what I’m assuming. I’d rather install the current beta than go back 4 months.

Are there any more serious problems known at endeavouros-2019.12.03-x86_64.iso so far? (And could joekamprad provide sha256 or similar also for betas? Not because you have to pull them all the time, but you could want to. :slight_smile: )

All I do upload to beta is only for testing nothing official.
I can put checksum and sig, and I wanted to do so but my time is very limited till end of January.
But you will find this ISO now at our official ISO repo at GitHub with sig and md5 for checking.

GDM is causing issues at the moment, I see here that I need to disable Wayland inside /etc/gdm/custom.conf

Uncommenting the line:
#WaylandEnable=false
Like this:
WaylandEnable=false

Also this:
https://wiki.archlinux.org/index.php/GDM#GDM_freezes_with_systemd

And this is possible:
https://wiki.archlinux.org/index.php/GDM#GDM_does_not_start_until_input_is_provided

You were early I am planning to make a new anouncemnet on it, in half an hour, when I’m done at work.

1 Like

Yes “a dynamic community”

:stuck_out_tongue_winking_eye:

Betas are usually only intended for testing purposes. Which does not necessarily mean that they cannot be used in a productive environment.

I don’t really have anything here that is final. But I also don’t burst into tears when a problem occurs (otherwise I could never use siduction ]:−) ).

But OK, I thought to myself that these are only your images, not “team images”. After all, they are on your webspace.

Could you give the model of your Laptop with Bios version ? A guy who uses Archlinux with latest kernel, mesa, Gnome and wayland with 2500U got it work on Huawei Matebook D14.

With Ryzen 2500u, 5.4 Kernel and :

iommu=pt

has to resolve it…

How did the Pointer Sisters sing? I’m so excited. :wink:

1 Like