Cannot login after installing endeavour gnome

I installed endeavour os gnome, and after rebooting when I tried to login it just shows incorrect password. I am sure I am using the correct password. I reinstalled and it happened again. I am guessing I did something wrong in the installation. Can you help me?
Thank you.
Please do not mind bad English.

Are you able to login into tty2? If yes then you can most probably disable gdm and use lightdm.

Could it be the keyboard layout you chose in Calamares?

1 Like

I chose American English, as far as I remember.

Do you have a US QWERTY keyboard layout?

If you can log into the command prompt,


followed by your language layout in

cat /etc/vconsole.conf

will show KEYMAP=???

cat /etc/locale.conf | grep LANG

cat /etc/locale.conf | grep LANG

This outputs :



cat /etc/vconsole.conf

Outputs :


And you are using a US keyboard?

Yes, I am using the US-QWERTY Keyboard.

IN = India, and the language is English. What I am tryng to find out if the DM is expecting xyz and getting xws - is that possible?

Which display manager are you using? It should be GDM, then enter:

sudo systemctl enable gdm

I am guessing it is not possible, as earlier in Ubuntu I was using the same configuration, the language as en_IN and the keyboard layout as US. It worked fine.
Although I have set to login automatically in the system, but I cannot use any sudo commands as it outputs the same : incorrect password.

So you can’t log in an root.

I have to go on the road now, but I will follow the thread. Sorry I can’t be of more help, but its not easy doing support on a mobile on the road :wink:

Good luck with the issue.

The error still persists. Sorry.

now try to log in.
If it logs in, do

sudo pacman -Syyu

and then take a look at your journals

then follow

systemctl enable --now lightdm

I would try to verify if keyboard layout is the one selected at installation by pressing CTRL+ALT+F2 and typing the password on login prompt. Does it show your current password?

1 Like

Once you have tried this, we will know if you can log in as root.

What happened when you tried logging in through the tty2?