Cannot Install 'wine'

Dear Friends

For more than two decades I am in floss and I am using MS-Bookshelf-'98 on ‘wine’ for my text works. And the last few months I am working on EOS – without any problem. But after the grub update problem killed my system and I tried to reinstall it before the solution appearing here.

In this new installation on my desktop I am not able to install ‘wine’ for using Bookshelf-98. And I have updated mirrors more than once. Though I can install ‘wine’ and use Bookshelf-98 on my desktop machine, that too being a new installation after the grub chaos.

Can anyone please help me?

Others will need more to go on. Errors, log snippets showing the failure, or something to go on.

Thanks, dear andrewb for responding. I am pasting here the whole output:
<<

yay -S wine
[sudo] password for dd:
resolving dependencies…
looking for conflicting packages…
warning: dependency cycle detected:
warning: lib32-harfbuzz will be installed before its lib32-freetype2 dependency
warning: dependency cycle detected:
warning: lib32-mesa will be installed before its lib32-libglvnd dependency
warning: dependency cycle detected:
warning: lib32-keyutils will be installed before its lib32-krb5 dependency

Package (75) New Version Net Change

community/faudio 22.09-1 0.36 MiB
multilib/lib32-acl 2.3.1-1 0.04 MiB
multilib/lib32-attr 2.5.1-1 0.02 MiB
multilib/lib32-brotli 1.0.9-4 0.80 MiB
multilib/lib32-bzip2 1.0.8-2 0.07 MiB
multilib/lib32-curl 7.85.0-1 0.68 MiB
multilib/lib32-dbus 1.14.0-1 0.39 MiB
multilib/lib32-e2fsprogs 1.46.5-1 0.56 MiB
multilib/lib32-expat 2.4.8-1 0.19 MiB
multilib/lib32-faudio 22.09.01-1 0.27 MiB
multilib/lib32-fontconfig 2:2.14.0-1 0.33 MiB
multilib/lib32-freetype2 2.12.1-1 0.79 MiB
core/lib32-gcc-libs 12.2.0-1 107.52 MiB
multilib/lib32-gettext 0.21-1 3.02 MiB
multilib/lib32-glib2 2.72.3-1 3.80 MiB
core/lib32-glibc 2.36-3 18.00 MiB
multilib/lib32-glu 9.0.2-3 0.34 MiB
multilib/lib32-harfbuzz 5.1.0-1 1.94 MiB
multilib/lib32-icu 71.1-1 34.67 MiB
multilib/lib32-keyutils 1.6.3-1 0.02 MiB
multilib/lib32-krb5 1.20-1 2.40 MiB
multilib/lib32-lcms2 2.13.1-1 0.41 MiB
multilib/lib32-libcap 2.65-1 0.07 MiB
multilib/lib32-libdrm 2.4.113-1 0.38 MiB
multilib/lib32-libelf 0.187-1 2.42 MiB
multilib/lib32-libffi 3.4.2-4 0.04 MiB
multilib/lib32-libgcrypt 1.10.1-1 0.98 MiB
multilib/lib32-libglvnd 1.4.0-3 1.32 MiB
multilib/lib32-libgpg-error 1.45-1 0.15 MiB
multilib/lib32-libice 1.0.10-1 0.10 MiB
multilib/lib32-libidn2 2.3.3-1 0.12 MiB
multilib/lib32-libjpeg-turbo 2.1.4-2 1.13 MiB
multilib/lib32-libldap 2.6.3-1 0.45 MiB
multilib/lib32-libnl 3.7.0-1 1.18 MiB
multilib/lib32-libpcap 1.10.1-1 0.37 MiB
multilib/lib32-libpciaccess 0.16-1 0.06 MiB
multilib/lib32-libpng 1.6.37-3 0.30 MiB
multilib/lib32-libpsl 0.21.1-2 0.07 MiB
multilib/lib32-libsm 1.2.3-1 0.04 MiB
multilib/lib32-libssh2 1.10.0-1 0.28 MiB
multilib/lib32-libtiff 4.4.0-4 0.64 MiB
multilib/lib32-libtirpc 1.3.3-1 0.20 MiB
multilib/lib32-libunistring 1.0-1 1.67 MiB
multilib/lib32-libunwind 1.6.2-1 0.17 MiB
multilib/lib32-libx11 1.8.1-1 1.33 MiB
multilib/lib32-libxau 1.0.9-2 0.01 MiB
multilib/lib32-libxcb 1.15-1 0.97 MiB
multilib/lib32-libxcrypt 4.4.28-2 0.16 MiB
multilib/lib32-libxcursor 1.2.1-1 0.04 MiB
multilib/lib32-libxdamage 1.1.5-2 0.01 MiB
multilib/lib32-libxdmcp 1.1.3-1 0.03 MiB
multilib/lib32-libxext 1.3.4-2 0.08 MiB
multilib/lib32-libxfixes 6.0.0-1 0.02 MiB
multilib/lib32-libxi 1.8-1 0.08 MiB
multilib/lib32-libxml2 2.10.2-2 1.48 MiB
multilib/lib32-libxrandr 1.5.2-2 0.06 MiB
multilib/lib32-libxrender 0.9.10-3 0.05 MiB
multilib/lib32-libxshmfence 1.3-2 0.01 MiB
multilib/lib32-libxxf86vm 1.1.4-3 0.02 MiB
multilib/lib32-llvm-libs 14.0.6-2 121.35 MiB
multilib/lib32-lm_sensors 1:3.6.0.r41.g31d1f125-1 0.06 MiB
multilib/lib32-mesa 22.1.7-1 62.40 MiB
multilib/lib32-ncurses 6.3-1 0.61 MiB
multilib/lib32-openssl 1:1.1.1.q-1 3.33 MiB
multilib/lib32-pam 1.5.2-1 0.80 MiB
multilib/lib32-pcre 8.45-1 1.39 MiB
multilib/lib32-sdl2 2.0.22-1 1.75 MiB
multilib/lib32-systemd 251.4-1.1 1.92 MiB
multilib/lib32-util-linux 2.38.1-1 1.05 MiB
multilib/lib32-vulkan-icd-loader 1.3.226-1 0.52 MiB
multilib/lib32-wayland 1.21.0-1 0.16 MiB
multilib/lib32-xz 5.2.6-1 0.18 MiB
multilib/lib32-zlib 1.2.12-1 0.09 MiB
multilib/lib32-zstd 1.5.2-1 0.63 MiB
multilib/wine 7.16-2 511.39 MiB

Total Installed Size: 900.75 MiB

:: Proceed with installation? [Y/n] Y
:: Retrieving packages…
faudio-22.09-1-x86_64.pkg.tar.zst failed to download
error: failed retrieving file ‘faudio-22.09-1-x86_64.pkg.tar.zst’ from mirror.guillaumea.fr : The requested URL returned error: 404
error: failed retrieving file ‘faudio-22.09-1-x86_64.pkg.tar.zst’ from mirror.archlinux.tw : The requested URL returned error: 404
error: failed retrieving file ‘faudio-22.09-1-x86_64.pkg.tar.zst’ from archlinux.cs.nycu.edu.tw : The requested URL returned error: 404
error: failed retrieving file ‘faudio-22.09-1-x86_64.pkg.tar.zst’ from mirror.sahil.world : The requested URL returned error: 404
error: failed retrieving file ‘faudio-22.09-1-x86_64.pkg.tar.zst’ from mirrors.abhy.me : The requested URL returned error: 404
error: failed retrieving file ‘faudio-22.09-1-x86_64.pkg.tar.zst’ from mirror.jingk.ai : The requested URL returned error: 404
error: failed retrieving file ‘faudio-22.09-1-x86_64.pkg.tar.zst’ from mirrors.nxtgen.com : The requested URL returned error: 404
error: failed retrieving file ‘faudio-22.09-1-x86_64.pkg.tar.zst’ from mirrors.42tm.tech : The requested URL returned error: 404
error: failed retrieving file ‘faudio-22.09-1-x86_64.pkg.tar.zst’ from shadow.ind.ntou.edu.tw : The requested URL returned error: 404
error: failed retrieving file ‘faudio-22.09-1-x86_64.pkg.tar.zst’ from mirror.gi.co.id : The requested URL returned error: 404
warning: failed to retrieve some files
error: failed to commit transaction (failed to retrieve some files)
Errors occurred, no packages were upgraded.
→ error installing repo packages
[dd@manu ~]$

Maybe this ‘faudio-22.09-1-x86_64.pkg.tar.zst’ has got something to do with it. Every time after showing this name it is standing still for some time and then the error messages follow.

Waiting eagerly for your response. I take the laptop with me to my college, and use BS-'98 every now and then.

My guess is that you system is not “up to date” and you are trying to install old package that does not exists any more.

Try to first update running yay and then install new package with yay -S wine.
Or you canb just run yay -Syu wine to do it in one step.

I do not know how old is your log but current version of wine is 7.17-1.

It looks like mirror issue.

First install rate-mirrors by : yay -S rate-mirrrors.

Then, in terminal, execute the following:

rate-mirrors arch | sudo tee /etc/pacman.d/mirrorlist

And after that perform full system update as told by @vlkon .
1 Like

faudio-22.09-1 got in the main Arch Community repo on 2022-09-03, about a week ago. Those mirrors might not have sync’d since then. That’s almost an eternity for mirrors!

Thank you andrewb, PhoenixAwakened, and vikon.

All my problems are solved for now. Actually it was my own doing. From that grub calamity that broke down both my systems and I reinstalled on both of them, I was so afraid to do a system update, as all the hell broke loose from that innocent ‘yay -Syu’ and both the machines were booting into bios again and again like a Myth of Sisyphus.

And now, emboldened by your suggestions, dear friends, I did it on both the laptop and the desktop and they are working fine. This forum is really nice.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.