Cannot install on Dell M6500 with Nvidia Quadro FX3800M

Hi there,

I have a Dell Precision M6500 with Core I7 and an Nvidia Quadro FX3800M.

I had installed Linux Mint 20.1 Cinnnamon on it and thought I was experienced enough to install EndevourOS.

I came to it via a few detours. First I upgraded Linux Mint to 21.1 and noticed for the first time that due to the ended driver support from NVIDIA for my graphics card, the desktop could not be loaded. I also tried Manjaro Linux with the same result, except that the graphical user interface could be loaded for installation without any problems. The instructions to change the start parameters at least brought me to the command line, where I could also log in. From there I installed the various free drivers and tried them out. Unfortunately, the result was always the same.

Now I had the hope that it would run better with EndevourOS. Unfortunately, I was wrong again.

Only with the “Fallback” option do I get to the welcome screen and can then log in CRTL+SHIFT+F2. But since I don’t know the login data, I can unfortunately also grab the desired LOG files.

How do I manage

  1. install EndevourOS
  2. start it in such a way that I can also work with the desktop.

PS: EndevourOS has been running on my main computer for a few months and I am working on replacing Windows.

Your Nvidia GPU is very old, and the available Nvidia driver of Arch does not support it.
But you can use the nouveau kernel driver instead.

Or if you have an integrated Intel GPU, you can use that. With Intel you can try with or without the xf86-video-intel package, which one works better.

You may also blacklist the GPU driver that you will not use.

So, to install, try the boot menu selections and use the one that seems to work.

1 Like

I haven’t had my m6500 out in a while, so some of this is from memory:

Technically, the official Nvidia drivers for your card are not supported with recent kernels. That said, there are some valiant individuals who manage to keep it working. Try installing the 340-series Nvidia driver from the AUR (nvidia-340xx-dkms). I’d also consider switching to the LTS kernel.

Hi there,

Thank you for your answers. Unfortunately, I see only one tiny problem. The installer won’t start for me and I don’t have the access data to install via the command line.

So I will probably stay with Windows or switch back to Mint 20.1.

Just a question: did you use the latest available ISO (Cassini neo) or an older one?

it’s the latest Cassini Neo build from ISO to USB

1 Like

The FX3800M takes the 340.xx drivers. Not sure why the installer won’t start but i had one other user have the same issue so i would suggest to try downloading another ISO from a different mirror and create a new live usb. It may be a bad download or there is a bad ISO out there at one of the links.

Edit: The other user had no issues after downloading another ISO from a different mirror and creating a new live usb.

1 Like

One thing to try is to add the argument “nouveau.modeset=0” to the boot arguments when booting the installer.


Yes, tried. Same situation. But interesting fact, I also tried to install Arco Linux XL and guess what happened. The installer is working with the installer option “Nomodeset”

I’m not sure that it also starts…

I’m now take a closer lok to the installer options…