Cannot get line in input to be detected

Been stumped for a couple hours on this issue. I’m trying to use the line in jack on my motherboard but it’s just completely refusing to show in the sound settings. Out of the three ports (line in, line out, mic in) the only one that seems to work is the line out, which is the main output I use.

inxi output for audio:

Audio:
  Device-1: NVIDIA GA104 High Definition Audio vendor: eVga.com.
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 2b:00.1 chip-ID: 10de:228b class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 2d:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: MACROSILICON ShadowCast
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-4.4:3 chip-ID: 298f:1996
    class-ID: 0300
  Device-4: WaveRider USB 2.0 Camera driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1:8
    chip-ID: 0c46:636b class-ID: 0102 serial: <filter>
  Device-5: C-Media Blue Snowball driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 5-4:4
    chip-ID: 0d8c:0005 class-ID: 0300 serial: <filter>
  API: ALSA v: k6.6.7-zen1-1-zen status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl

I’ve tried messing around with alsamixer as well but couldn’t seem to get anywhere. I’m a bit clueless when it comes to audio, so any direction on what to do would be appreciated.

Do the inputs show up in alsamixer at least, or no? Have you tried switching the sound card with F6?

Assuming this is what it’s supposed to look like, the inputs do show up when navigating to the correct sound card. They still are not selectable from inside any other application.

See if you can select the other capture and toggle it on with Space.

Here is the Alsa-related “No microphone input” troubleshooting section in the wiki if you haven’t seen it yet: https://wiki.archlinux.org/title/Advanced_Linux_Sound_Architecture/Troubleshooting#No_microphone_input

Here is the PipeWire related one: https://wiki.archlinux.org/title/PipeWire#Microphone_is_not_detected_by_PipeWire

The PipeWire one says it may be worth a shot to turn off api.alsa.use-acp or turn on api.alsa.use-ucm by setting options in /etc/wireplumber/main.lua.d/50-alsa-config.lua:

/etc/wireplumber/main.lua.d/50-alsa-config.lua (or ~/.config/wireplumber/main.lua.d/50-alsa-config.lua)
...
alsa_monitor.rules = {
    {
        ...
        apply_properties = {
            -- Use ALSA-Card-Profile devices. They use UCM or the profile
            -- configuration to configure the device and mixer settings.
            -- ["api.alsa.use-acp"] = true,
 
            -- Use UCM instead of profile when available. Can be
            -- disabled to skip trying to use the UCM profile.
            ["api.alsa.use-ucm"] = true,
...

You would comment out the one with “--” and/or uncomment the other.

Device was working with arecord, so it looks like all it took was adding the device manually. Added the config file at /etc/pipewire/pipewire.conf.d/linein.conf and everything seems to be good. Thank you for the help!