Cannot get external monitor working

I have Gigabyte AERO 16 YE5 with hybrid graphics (Alder Lake-P Integrated Graphics Controller and GeForce RTX 3080 Ti Mobile). Whatever I try, the external monitor I connect to the DP port doesn’t work. It works in Manjaro, it works in Windows, no luck with EndeavourOS.

I use XFCE, no Wayland. I did

nvidia-inst --prime

The kernel command line in grub.cfg has nvidia-drm.modeset=1, I also tried

MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)

in /etc/mkinitcpio.conf and sudo mkinitcpio -P, no positive results, the only effect is the system hangs for a minute or two on boot.


$ xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x49 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 5 outputs: 6 associated providers: 0 name:Intel
$ glxinfo | grep "OpenGL renderer"
OpenGL renderer string: Mesa Intel(R) Graphics (ADL GT2)
$ xrandr
Screen 0: minimum 8 x 8, current 3840 x 2400, maximum 32767 x 32767
eDP1 connected primary 3840x2400+0+0 (normal left inverted right x axis y axis) 340mm x 220mm
   3840x2400     60.00*+
   3840x2160     59.97  
   3200x1800     59.96    59.94  
   2880x1620     59.96    59.97  
   2560x1600     59.99    60.00    59.97  
   2560x1440     59.96    59.95  
   2048x1536     60.00  
   1920x1440     60.00  
   1856x1392     60.01  
   1792x1344     60.01  
   2048x1152     59.90    59.91  
   1920x1200     59.88    60.00    59.95  
   1920x1080     59.96    59.93  
   1600x1200     60.00  
   1680x1050     60.00    59.95    59.88  
   1400x1050     59.98  
   1600x900      59.95    59.82  
   1280x1024     60.02  
   1400x900      60.00    59.96    59.88  
   1280x960      60.00  
   1368x768      59.88    59.85  
   1280x800      59.81    60.00    59.91  
   1280x720      59.86    59.74  
   1024x768      60.00  
   1024x576      59.90    59.82  
   960x540       59.63    59.82  
   800x600       60.32    56.25  
   864x486       59.92    59.57  
   640x480       59.94  
   720x405       59.51    58.99  
   640x360       59.84    59.32  
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)
DP4 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
$ inxi -G
  Device-1: Intel Alder Lake-P Integrated Graphics driver: i915 v: kernel
  Device-2: NVIDIA GA103M [GeForce RTX 3080 Ti Mobile] driver: N/A
  Device-3: Goodong USB Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: intel
    unloaded: modesetting dri: i965 gpu: i915 resolution: 3840x2400~60Hz
  API: OpenGL v: 4.6 Mesa 22.2.1 renderer: Mesa Intel Graphics (ADL GT2)
$ lsmod | grep -i nvidia
nvidia              60055552  1

The funny thing is, if I unplug and plug in the display back again, the OS detects it and pops up a display settings dialog, where strangely there is no second display at all.

The problem was kind of “resolved” by switching to the LTS kernel. “Kind of” because despite the fact the external monitor shows graphics, the system became super sluggish. The UI pauses for a second before it reacts on any mouse click or on keyboard typing. I consider it as still “not working”.

There is no driver loaded for the Nvidia card and it’s running on Intel graphics.

Your Nvidia card is supported by the latest Nvidia drivers. No drivers are loaded.

Device-2: NVIDIA GA103M [GeForce RTX 3080 Ti Mobile] driver: N/A

Did you install the nvidia drivers? Also you need ibt=off as a kernel parameter in the default grub command line in /etc/default/grub

Then you need to update grub with sudo grub-mkconfig -o /boot/grub/grub/cfg

I don’t think you read my post carefully. Yes, the driver is installed and in fact is loaded.

It’s not loaded. You need to add the kernel parameter and update grub with the proper command.

Edit: Normally on laptops when connecting an external monitor through DP it would run on Nvidia. There is an issue and that is why you need the kernel parameter. Not sure you need prime?

Edit: You can use nano and edit the default grub command line.

sudo nano /etc/default/grub



ctrl + o then enter to save the file
ctrl + x to exit nano

Then update grub

sudo grub-mkconfig -o /boot/grub/grub.cfg

Then reboot

After show the following,

inxi -Ga
$ lsmod | grep -i nvidia
nvidia              60055552  1

It’s not loaded for the third time. Please try the solution i gave you with the kernel parameter or i cannot help you.

Edit: Being installed and loading are two different things!

For the third time: lsmod lists currently loaded modules.

Did you try the parameter for the 4th time?

Edit: It’s obvious you don’t want or need any help.

See my second post. LTS kernel is 5.15. You need ibt=off for 5.18. I switched to Manjaro.

I don’t believe it’s just needed with the current kernel necessarily. It’s an issue with that generation of CPU and Nvidia. But hey nothing wrong with Manjaro if that’s what you want. I’m just disappointed you wouldn’t try what i asked you to. Good luck!

Sorry I disappointed you. I am an NVIDIA system engineer, I simply know when advice is useless for me.