Cannot connect to WiFi with newly installed EndeavourOS

Hello all, today I just returned to this great system that reminds me so much of Antergos.

I find the surprise of his change to KDE, but especially that I can not connect to the WiFi and the truth is that I can not find a way to do so.

My computer is: Laptop LENOVO ThinkPad T420

Can you give me some indication?.

Thanks

Hi @Quijote_Libre Welcome to the forum.

I’m no expert, but…

Did wifi work in the live session?
If so, please have a look here:

If that does not help at all, please provide some info on your wifi device by running:

inxi -Na

It should yield output like:

Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 01:00.1 chip-ID: 10ec:8168
    class-ID: 0200
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: Lite-On driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280

This information will help others, more knowledgeable than me, to help you.

1 Like

Thank you for trying to help me :blush:.

The wifi did not work with the live install, nor did it work once installed.

I had a try with the normal kernel and a try with the zen kernel.

The information requested:

$ inxi -Na
Network:
  Device-1: Intel 82579LM Gigabit Network vendor: Lenovo ThinkPad T520
    driver: e1000e v: kernel port: 3040 bus-ID: 00:19.0 chip-ID: 8086:1502
    class-ID: 0200
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
    v: kernel modules: wl pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0
    chip-ID: 8086:0085 class-ID: 0280

:face_with_hand_over_mouth: In the end I have a solution, I have no idea how, although it seems to be a problem with my phone.

First, I saw this with another phone connecting.

As you can see here, my connection appears twice

$ nmcli device wifi list
IN-USE  BSSID              SSID        MODE   CHAN  RATE        SIGNAL  BARS  SECURITY  
        7E:D2:61:54:E4:F6  Pixel-asim  Infra  7     130 Mbit/s  82      ▂▄▆█  WPA2 WPA3 
*       7E:2D:9E:54:E4:F6  Pixel-asim  Infra  161   270 Mbit/s  70      ▂▄▆_  WPA2 WPA3 

I had to configure the connection by hand, and it did get connected.

This page helped me

1 Like

Great that you got things working; I’m not sure what your phone could be doing to prevent your pc from connecting to wifi, though. Still, one lives and learns. :slight_smile:

If the issue is solved could you mark your question as solved, please? That helps others, with the same problem, to find a solution.

1 Like

Done and thanks @SemLraug

@Quijote_Libre glad you have it working and Welcome to the forums. :wave:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.