Cannot boot after updating keyring

I did
sudo pacman -Sy endeavouros-keyring
sudo pacman -Syu

Now the computer will not get past
loading ramdisk after reboot

What can I do?

You can try booting to TTY if pressing keys Ctrl-Alt-F3 gives you a terminal like full screen. There you can do almost any terminal command.

If that doesn’t work, you can boot with the USB installer and arch-chroot into your system. Then you can do almost any command.

The reason can be e.g. failing updates or shutting down before update is fully ready.
You could give us some logs, e.g.

sudo journalctl -b -1 | eos-sendlog

(post the returned address here).

1 Like

I tried Ctrl-Alt-F3 with no luck.
I mounted the root disk from live iso and arch-chroot into /mnt

sudo journalctl -b -1 | eos-sendlog

did not give any return address

did I miss something?

1 Like

Alternatively, you could look into your pacman.log, if something went wrong during the last system-update.

Or you could reinstall kernels and/ or your boot-manager… or… graphic drivers, or… depending on your system setup, which is somewhat obscured by clouds on my crystal ball here, so please forgive me. :wink:


Always a good idea from within the chroot-environment:

Update your system. :wink:

everything seems to be up to date from within the chroot-environment.
it is a mac mini with dual boot osx and enos - boots normally automatically with grub only showing the linux and when I boot osx it is with the ALT key

but after the keyring update I cannot boot into enos

So what does your pacman-log show? Which were the packages updated last, before you couldn’t boot your system (this shouldn’t have anything to do with the keyring-issue)??!

From within the chroot-environment, run eos-log-tool and check EndeavourOS Install log…

What is the right way to show the pacman.log (huge) when eos-sendlog don’t give any address… access denied due to firewall policy

cat /var/log/pacman.log | grep fail | eos-sendlog
cat /var/log/endeavour-install.log | grep fail | eos-sendlog
In order to view the cat results yourself, without uploading them to the internet, just drop this part: | eos-sendlog …and… | grep xyz - gives you a filter-option, see above.

Fwiw, /var/log/pacman.log is world readable so there is no need for sudo to cat its content:

 ls -l /var/log/pacman.log 
-rw-r--r-- 1 root root 1778789 May 27 11:14 /var/log/pacman.log
1 Like

Ah… so I was being too “quick & dirty”. Thank you again, @pebcak !


EDIT: I edit sudo out from my previous post, for correctness. :wink:

That question is above my head, also.

Maybe, someone else can tell? - @manuel ?

Skip to the bottom, find the timestamps for that specific update and copy/paste only that part of the log here.

Pastebin services are occasionally unstable, we have had to change the service a few times already.
But currently eos-sendlog seems to work here, so if firewall is doing something to prevent it, the firewall rules might not be correct.

Allright, eos-sendlog works now using another wifi…so here is the pacman.log

That’s a mess.

It is only showing errors, and nothing else.

Can you try running the same commands now, again?

sudo pacman -Sy endeavouros-keyring && sudo pacman -Syu

In case of any errors, try refreshing your mirrors first.

1 Like

It’s done now. Here is the new pacman.log?

That log is showing the same errors. Did you refresh your mirrors?

Still only errors on pacman.log. Is your internet connection working properly?


right now it is running through a android phone, when i first did the update when the problems started I was using a good fast wifi connection