Cannot bind Meta to anything different that launcher KDE

Hi all,
I’m messing around with KDE a bit and I would like to bind meta key (I know that I’ve to use alt+f1 as a shortcut) to something other than the launcher (binding the key to the launcher works without problem). I’m wondering, is this a limit of KDE or just me that I’m doing something wrong? Specifically I would like to bind it so that it launches the overview.

Thanks in advance!

I don’t think you can rebind it using KDE settings, however, you can use Ksuperkey to make your meta key act as another key. Ksuperkey defaults to alt+F1, but can be configured to something else if you want it to, and then bind that to launch overview. If you do not like the default mapping, instructions for how to configure it can be found on Github.

1 Like

What do you want to bind your meta key to do?

On the flip side - you may want to bind your caps lock key to it. I have mine set as another meta key for instance, but you can easily set it for escape, return, shift, backspace and more.

:point_up_2:t5:

Jesus I’m an idiot. I’ve really gotta read better.

Ok. Well - if you click on the application launcher- you can remove the alt+f1 keybinding.

You should then be able to set overview to alt+f1

And I still stand by my suggestion to use caps lock for it. It’s under advanced keyboards.

I also believe there’s a setting to change the “meta/super key” to alt+f4 to use the left alt let instead like in i3 which may allow you to set it to alt-f1

That doesn’t work, that’s why I was asking. If I remove alt+f1 from launcher and set it up to overview simply nothing happens when I press meta. Have tried to reboot also after even if it shouldn’t be necessary but nothing changed either.

This can be done with xcape.

Having fun? :smile:

It’s not only you that wants to rebind to the Overview.
There is a solution, as reported.

kwriteconfig5 --file ~/.config/kwinrc --group ModifierOnlyShortcuts --key Meta "org.kde.kglobalaccel,/component/kwin,org.kde.kglobalaccel.Component,invokeShortcut,Overview"
qdbus org.kde.KWin /KWin reconfigure
kwriteconfig5 --file kwinrc --group ModifierOnlyShortcuts --key Meta "org.kde.kglobalaccel,/component/kwin,,invokeShortcut,Overview"

Source:
https://old.reddit.com/r/kde/comments/ppxrbg/assign_meta_key_to_overview_effect/

EDIT :

Oops … already solved.

:blush:

1 Like

Oh wow! How have I miss that! Odd that it doesn’t work using the shortcut menù. I’ll try this evening. Thanks everyone

Actually more than I initially thought I would have!

EDIT: worked perfectly, thanks again!

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.