Cannot access my main system, grub is broken after I updated

So I don’t update frequently, today I updated and went to reboot, system went to bios after the “Welcome to Grub” message. Have been on online forums for the past 2 hours looking how to fix this. So far I have gotten as far as this: Have a live system and chroot into my main one (nvme0n1p3 for me), tried to grub-install from there and got “error: cannot find EFI directory” so i did fdisk -l and saw that /dev/sdb2 is type EFI (FAT-12/16/32), next thing I tried was grub-install —efi-directory=/dev/sdb2 and got “error: failed to get canonical path of `udev’. “

I would also like to add that on my main system I have my boot, root and home partitioned separately they are nvme0n1p1, nvme0n1p3 and nvme0n1p4 respectively (nvme0n1p2 is a swap partition).

Thats all, I just wanted to get some help since I honestly have no idea how to fix this, I’m also not the most experienced when it comes to linux but I will follow any suggestions I get.

Thank you in advance!

The instructions to fix that are here:

Also, you really need to update more frequently than that.

Welcome to the forum!

That was the first post I came across, two issues I faced, the link in step 2 doesn’t work anymore and second I have done everything up until “grub-install” which like I mentioned doesn’t work properly. Thats what I was asking for help with.
Thank you for taking the time to respond!

The link is still working.

The instructions say to run the command grub-install from within the chroot. You are running grub-install --efi-directory=/dev/sdb2. Just run grub-install with no other options.

The link takes me to “ It seems we can’t find what you’re looking for. Perhaps searching can help.” and like I said in my original post “grub-install” returns “error: cannot find EFI directory.”

I guess it was merged to another one. Try this:

That means you probably didn’t mount your EFI partition in the chroot.

Please reboot to get a clean environment and then share the output of all the steps so we can see what is going wrong.

Also, please share the output of lsblk -o name,type,fstype,size,uuid

Maybe this is the latest chroot help page:

Okay, I’m back, so I got grub to work again but now I’m faced with a different issue.
I go to boot up and it stops right after “reached target Graphical Interface”.
My cursor also appears on the screen at that point if that’s relevant.

That usually indicates an issue with the graphics driver.

What is your hardware? CPU/GPU.

CPU: intel core i7 7th Gen
GPU: Nvidia GeForce GTX 1050 mobile

Can you post the output of command

inxi -Gza | eos-sendlog

The URL from the output is needed.

It outputs the following:

The nvidia driver is not in use. Were you using the integrated Intel GPU before?

What does the following show:

pacman -Qs nvidia

Isn’t the inxi from the ISO?

Probably yes, sorry about this confusion.

Can you use the TTY, e.g. by pressing keys Ctrl-Alt-F3 when on the blank screen after a reboot?

Yup, thats where I have been putting the commands in, also pacman -Qs nvidia returns:
libvdpau(1.5-1), nvidia-inst(1.8-1) and nvidia-installer-common(1.7-2)

Can you try uninstalling xf86-video-intel and rebooting?

I uninstalled it and rebooted, same result, boot up screen freezes at “Reached target Graphical Interface”.

anything in the logs? journalctl -b -p err